{"answers":{"affected":"2 open source packages ship an affected version, including keystone. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-9240 in the wild and no public exploit code.","fix":"Upgrade keystone to 0.3.16 or later.","what":"CVE-2015-9240 is a high-severity authentication bypass vulnerability in HackerOne keystone node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-9240 and fix it if it is affected.\n\nWhat it is: CVE-2015-9240 is a high-severity authentication bypass vulnerability in HackerOne keystone node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-9240 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- keystone (npm): affected all versions; fixed in 0.3.16\n- keystone (npm): affected all versions; fixed in 0.3.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-9240/ (Markdown: https://insights.sbomify.com/CVE-2015-9240/index.md)","id":"CVE-2015-9240","markdown":"https://insights.sbomify.com/CVE-2015-9240/index.md","name":"CVE-2015-9240","record":{"aliases":["GHSA-39pj-gq8q-9pfj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js authentication library","requires_auth":"none","summary":"Incomplete email matching in the keystone library allows attackers to bypass authentication checks, potentially leading to account takeover.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"keystone","vendor":"keystonejs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-255","name":null}],"description":"Due to a bug in the the default sign in functionality in the keystone node module before 0.3.16, incomplete email addresses could be matched. A correct password is still required to complete sign in.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Weakness in keystone","id":"CVE-2015-9240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2015"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of Service in hapi","id":"CVE-2015-9241"},"packages":[{"ecosystem":"npm","fixed":["0.3.16"],"introduced":["0"],"last_affected":[],"package":"keystone","purl":null,"source":"GHSA-39pj-gq8q-9pfj"},{"ecosystem":"npm","fixed":["0.3.16"],"introduced":["0"],"last_affected":[],"package":"keystone","purl":"pkg:npm/keystone","source":"GHSA-39pj-gq8q-9pfj"}],"prev":{"headline":"Regular Expression Denial of Service in ansi2html","id":"CVE-2015-9239"},"products":["keystone node module"],"published":"2018-05-29","related":[{"cvss_score":9.8,"headline":"NODE_ENV in Keystone defaults to development with esbuild","id":"CVE-2022-39382","kev_date_added":null,"published":"2022-11-03"},{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2022-29354","kev_date_added":null,"published":"2022-05-16"},{"cvss_score":9.1,"headline":"@keystone-6/core vulnerable to field-level access-control bypass for multiselect field","id":"CVE-2022-39322","kev_date_added":null,"published":"2022-10-25"},{"cvss_score":8.8,"headline":"Cross-Site Request Forgery (CSRF) in keystone","id":"CVE-2017-16570","kev_date_added":null,"published":"2017-11-06"},{"cvss_score":8.8,"headline":"Keystone is vulnerable to CSV injection","id":"CVE-2017-15879","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":7.1,"headline":"Cross-site Scripting (XSS) - Reflected in keystonejs/keystone","id":"CVE-2022-0087","kev_date_added":null,"published":"2022-01-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Incomplete email matching in the keystone library allows attackers to bypass authentication checks, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2015-9240/"}