{"answers":{"affected":"2 open source packages ship an affected version, including hapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-9241 in the wild and no public exploit code.","fix":"Upgrade hapi to 11.1.3 or later.","what":"CVE-2015-9241 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-9241 and fix it if it is affected.\n\nWhat it is: CVE-2015-9241 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-9241 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hapi (npm): affected all versions; fixed in 11.1.3\n- hapi (npm): affected all versions; fixed in 11.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-9241/ (Markdown: https://insights.sbomify.com/CVE-2015-9241/index.md)","id":"CVE-2015-9241","markdown":"https://insights.sbomify.com/CVE-2015-9241/index.md","name":"CVE-2015-9241","record":{"aliases":["GHSA-rc8h-3fv6-pxv8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"An attacker can cause a denial of service by sending malformed headers that keep sockets open until timeout, affecting hapi users.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"hapi","vendor":"hapijs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Certain input passed into the If-Modified-Since or Last-Modified headers will cause an 'illegal access' exception to be raised. Instead of sending a HTTP 500 error back to the sender, hapi node module before 11.1.3 will continue to hold the socket open until timed out (default node timeout is 2 minutes).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in hapi","id":"CVE-2015-9241","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of Service in ecstatic","id":"CVE-2015-9242"},"packages":[{"ecosystem":"npm","fixed":["11.1.3"],"introduced":["0"],"last_affected":[],"package":"hapi","purl":null,"source":"GHSA-rc8h-3fv6-pxv8"},{"ecosystem":"npm","fixed":["11.1.3"],"introduced":["0"],"last_affected":[],"package":"hapi","purl":"pkg:npm/hapi","source":"GHSA-rc8h-3fv6-pxv8"}],"prev":{"headline":"Authentication Weakness in keystone","id":"CVE-2015-9240"},"products":["hapi node module"],"published":"2018-05-29","related":[{"cvss_score":7.5,"headline":"Denial of Service via malformed accept-encoding header in hapi","id":"CVE-2017-16013","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":5.9,"headline":"Unsafe Merging of CORS Configuration Conflict in hapi","id":"CVE-2015-9243","kev_date_added":null,"published":"2018-05-29"},{"cvss_score":5.3,"headline":"Incorrect handling of CORS preflight request headers in hapi","id":"CVE-2015-9236","kev_date_added":null,"published":"2018-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"An attacker can cause a denial of service by sending malformed headers that keep sockets open until timeout, affecting hapi users.","url":"https://insights.sbomify.com/CVE-2015-9241/"}