# CVE-2015-9241: Denial of Service in hapi

> An attacker can cause a denial of service by sending malformed headers that keep sockets open until timeout, affecting hapi users.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rc8h-3fv6-pxv8

## What is CVE-2015-9241?

CVE-2015-9241 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Certain input passed into the If-Modified-Since or Last-Modified headers will cause an 'illegal access' exception to be raised. Instead of sending a HTTP 500 error back to the sender, hapi node module before 11.1.3 will continue to hold the socket open until timed out (default node timeout is 2 minutes).

Weakness: CWE-20 (Improper Input Validation), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2015-9241?

2 open source packages ship an affected version, including hapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hapi` | npm | All versions | 11.1.3 |
| `hapi` | npm | All versions | 11.1.3 |

Products: Hapijs Hapi.

## How do I fix CVE-2015-9241?

Upgrade hapi to 11.1.3 or later.

## Is CVE-2015-9241 being exploited?

There is no known exploitation of CVE-2015-9241 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne hapi node module

- [CVE-2017-16013](https://insights.sbomify.com/CVE-2017-16013/): Denial of Service via malformed accept-encoding header in hapi (high 7.5)
- [CVE-2015-9243](https://insights.sbomify.com/CVE-2015-9243/): Unsafe Merging of CORS Configuration Conflict in hapi (medium 5.9)
- [CVE-2015-9236](https://insights.sbomify.com/CVE-2015-9236/): Incorrect handling of CORS preflight request headers in hapi (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-9241 and fix it if it is affected.

What it is: CVE-2015-9241 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-9241 in the wild and no public exploit code.

Affected packages and fixed versions:
- hapi (npm): affected all versions; fixed in 11.1.3
- hapi (npm): affected all versions; fixed in 11.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-9241/ (Markdown: https://insights.sbomify.com/CVE-2015-9241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-9241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-9241
- OSV: https://osv.dev/vulnerability/CVE-2015-9241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-9241/
Summaries are generated and may contain mistakes; the official description above is the record.
