{"answers":{"affected":"2 open source packages ship an affected version, including ecstatic. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-9242 in the wild and no public exploit code.","fix":"Upgrade ecstatic to 1.4.0 or later.","what":"CVE-2015-9242 is a high-severity denial of service vulnerability in HackerOne ecstatic node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-9242 and fix it if it is affected.\n\nWhat it is: CVE-2015-9242 is a high-severity denial of service vulnerability in HackerOne ecstatic node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-9242 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ecstatic (npm): affected all versions; fixed in 1.4.0\n- ecstatic (npm): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-9242/ (Markdown: https://insights.sbomify.com/CVE-2015-9242/index.md)","id":"CVE-2015-9242","markdown":"https://insights.sbomify.com/CVE-2015-9242/index.md","name":"CVE-2015-9242","record":{"aliases":["GHSA-vwjc-q9px-r9vq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js static file server","requires_auth":"none","summary":"An attacker can crash the ecstatic server by sending a malformed If-Modified-Since header, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"ecstatic","vendor":"ecstatic_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Certain input strings when passed to new Date() or Date.parse() in ecstatic node module before 1.4.0 will cause v8 to raise an exception. This leads to a crash and denial of service in ecstatic when this input is passed into the server via the If-Modified-Since header.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in ecstatic","id":"CVE-2015-9242","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":2,"n_references":3,"next":{"headline":"Unsafe Merging of CORS Configuration Conflict in hapi","id":"CVE-2015-9243"},"packages":[{"ecosystem":"npm","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"ecstatic","purl":null,"source":"GHSA-vwjc-q9px-r9vq"},{"ecosystem":"npm","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"ecstatic","purl":"pkg:npm/ecstatic","source":"GHSA-vwjc-q9px-r9vq"}],"prev":{"headline":"Denial of Service in hapi","id":"CVE-2015-9241"},"products":["ecstatic node module"],"published":"2018-05-29","related":[{"cvss_score":7.5,"headline":"Denial of Service in ecstatic","id":"CVE-2019-10775","kev_date_added":null,"published":"2020-01-02"},{"cvss_score":7.5,"headline":"Denial of Service in ecstatic","id":"CVE-2016-10703","kev_date_added":null,"published":"2017-12-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"An attacker can crash the ecstatic server by sending a malformed If-Modified-Since header, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2015-9242/"}