{"answers":{"affected":"2 open source packages ship an affected version, including hapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-9243 in the wild and no public exploit code.","fix":"Upgrade hapi to 11.1.4 or later.","what":"CVE-2015-9243 is a medium-severity vulnerability in HackerOne hapi node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-9243 and fix it if it is affected.\n\nWhat it is: CVE-2015-9243 is a medium-severity vulnerability in HackerOne hapi node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-9243 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hapi (npm): affected all versions; fixed in 11.1.4\n- hapi (npm): affected all versions; fixed in 11.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-9243/ (Markdown: https://insights.sbomify.com/CVE-2015-9243/index.md)","id":"CVE-2015-9243","markdown":"https://insights.sbomify.com/CVE-2015-9243/index.md","name":"CVE-2015-9243","record":{"aliases":["GHSA-j3g2-m5jj-6336"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"hapi node module","requires_auth":"none","summary":"Attackers can bypass CORS restrictions in hapi node module when multiple configuration levels are combined, allowing unauthorized cross-origin requests.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"hapi","vendor":"hapijs"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-254","name":null},{"id":"CWE-284","name":"Improper Access Control"}],"description":"When server level, connection level or route level CORS configurations in hapi node module before 11.1.4 are combined and when a higher level config included security restrictions (like origin), a higher level config that included security restrictions (like origin) would have those restrictions overridden by less restrictive defaults (e.g. origin defaults to all origins `*`).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsafe Merging of CORS Configuration Conflict in hapi","id":"CVE-2015-9243","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2015"},"n_packages":2,"n_references":2,"next":{"headline":"SQL Injection in mysql","id":"CVE-2015-9244"},"packages":[{"ecosystem":"npm","fixed":["11.1.4"],"introduced":["0"],"last_affected":[],"package":"hapi","purl":null,"source":"GHSA-j3g2-m5jj-6336"},{"ecosystem":"npm","fixed":["11.1.4"],"introduced":["0"],"last_affected":[],"package":"hapi","purl":"pkg:npm/hapi","source":"GHSA-j3g2-m5jj-6336"}],"prev":{"headline":"Denial of Service in ecstatic","id":"CVE-2015-9242"},"products":["hapi node module"],"published":"2018-05-29","related":[{"cvss_score":7.5,"headline":"Denial of Service via malformed accept-encoding header in hapi","id":"CVE-2017-16013","kev_date_added":null,"published":"2018-06-04"},{"cvss_score":7.5,"headline":"Denial of Service in hapi","id":"CVE-2015-9241","kev_date_added":null,"published":"2018-05-29"},{"cvss_score":5.3,"headline":"Incorrect handling of CORS preflight request headers in hapi","id":"CVE-2015-9236","kev_date_added":null,"published":"2018-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can bypass CORS restrictions in hapi node module when multiple configuration levels are combined, allowing unauthorized cross-origin requests.","url":"https://insights.sbomify.com/CVE-2015-9243/"}