# CVE-2015-9243: Unsafe Merging of CORS Configuration Conflict in hapi

> Attackers can bypass CORS restrictions in hapi node module when multiple configuration levels are combined, allowing unauthorized cross-origin requests.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-j3g2-m5jj-6336

## What is CVE-2015-9243?

CVE-2015-9243 is a medium-severity vulnerability in HackerOne hapi node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When server level, connection level or route level CORS configurations in hapi node module before 11.1.4 are combined and when a higher level config included security restrictions (like origin), a higher level config that included security restrictions (like origin) would have those restrictions overridden by less restrictive defaults (e.g. origin defaults to all origins `*`).

Weakness: CWE-254, CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2015-9243?

2 open source packages ship an affected version, including hapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hapi` | npm | All versions | 11.1.4 |
| `hapi` | npm | All versions | 11.1.4 |

Products: Hapijs Hapi.

## How do I fix CVE-2015-9243?

Upgrade hapi to 11.1.4 or later.

## Is CVE-2015-9243 being exploited?

There is no known exploitation of CVE-2015-9243 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne hapi node module

- [CVE-2017-16013](https://insights.sbomify.com/CVE-2017-16013/): Denial of Service via malformed accept-encoding header in hapi (high 7.5)
- [CVE-2015-9241](https://insights.sbomify.com/CVE-2015-9241/): Denial of Service in hapi (high 7.5)
- [CVE-2015-9236](https://insights.sbomify.com/CVE-2015-9236/): Incorrect handling of CORS preflight request headers in hapi (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-9243 and fix it if it is affected.

What it is: CVE-2015-9243 is a medium-severity vulnerability in HackerOne hapi node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-9243 in the wild and no public exploit code.

Affected packages and fixed versions:
- hapi (npm): affected all versions; fixed in 11.1.4
- hapi (npm): affected all versions; fixed in 11.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-9243/ (Markdown: https://insights.sbomify.com/CVE-2015-9243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-9243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-9243
- OSV: https://osv.dev/vulnerability/CVE-2015-9243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-9243/
Summaries are generated and may contain mistakes; the official description above is the record.
