# CVE-2015-9251: Cross-Site Scripting (XSS) in jquery


- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 Jan 2018
- **Updated:** 6 Aug 2024
- **Also known as:** ALPINE-CVE-2015-9251, AZL-109766, AZL-41228, AZL-45099, CLEANSTART-2026-FZ67762, CVE-2017-16012, GHSA-rmxg-73gg-4p98, UBUNTU-CVE-2015-9251

## What is CVE-2015-9251?

CVE-2015-9251 is a medium-severity vulnerability in Oracle Banking Platform, published on 18 Jan 2018. 

### Official description

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-9251?

14 open source packages ship an affected version, including org.webjars.npm:jquery, jQuery and jquery-rails. It affects 47 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.webjars.npm:jquery` | Maven | All versions | 1.12.2 |
| `org.webjars.npm:jquery` | Maven | All versions | 1.12.2 |
| `org.webjars.npm:jquery` | Maven | From 1.12.3 | 3.0.0 |
| `org.webjars.npm:jquery` | Maven | From 1.12.3 | 3.0.0 |
| `jQuery` | NuGet | All versions | 1.12.2 |
| `jQuery` | NuGet | All versions | 1.12.2 |
| `jQuery` | NuGet | From 1.12.3 | 3.0.0 |
| `jQuery` | NuGet | From 1.12.3 | 3.0.0 |
| `jquery-rails` | RubyGems | All versions | 4.2.0 |
| `jquery-rails` | RubyGems | All versions | 4.2.0 |
| `jquery` | npm | All versions | 1.12.2 |
| `jquery` | npm | All versions | 1.12.2 |
| `jquery` | npm | From 1.12.3 | 3.0.0 |
| `jquery` | npm | From 1.12.3 | 3.0.0 |

Products: Jquery Jquery, Oracle Agile Product Lifecycle Management for Process, Oracle Banking Platform, Oracle Business Process Management Suite, Oracle Communications Converged Application Server, Oracle Communications Interactive Session Recorder, Oracle Communications Services Gatekeeper, Oracle Communications Webrtc Session Controller, Oracle Endeca Information Discovery Studio, Oracle Enterprise Manager Ops Center, Oracle Enterprise Operations Monitor, Oracle Financial Services Analytical Applications Infrastructure, Oracle Financial Services Asset Liability Management, Oracle Financial Services Data Integration Hub, Oracle Financial Services Funds Transfer Pricing, Oracle Financial Services Hedge Management and Ifrs Valuations, Oracle Financial Services Liquidity Risk Management, Oracle Financial Services Loan Loss Forecasting and Provisioning, Oracle Financial Services Market Risk Measurement and Management, Oracle Financial Services Profitability Management and 27 more.

## How do I fix CVE-2015-9251?

Upgrade org.webjars.npm:jquery to a fixed version for your release line: 1.12.2 or 3.0.0.

## Is CVE-2015-9251 being exploited?

There is no known exploitation of CVE-2015-9251 in the wild and no public exploit code.

Public exploit code:

- https://github.com/halkichi0308/CVE-2015-9251 (github_poc): https://github.com/halkichi0308/CVE-2015-9251
- PoC para CVE-2015-9251 jQuery menor a 3.0.0. (github_poc): https://github.com/moften/CVE-2015-9251
- This repository contains a Proof of Concept (PoC) for CVE-2015-9251, a vulnerability in jQuery versions prior to 3.0.0 that allows attackers to perform Cross-Site Scripting (XSS) attacks under certain conditions. (github_poc): https://github.com/hackgiver/CVE-2015-9251
- cve-2015-9251 (github_poc): https://github.com/rox-11/xss

## Other vulnerabilities in Oracle Banking Platform

- [CVE-2016-10707](https://insights.sbomify.com/CVE-2016-10707/): Denial of Service in jquery (high 7.5)
- [CVE-2020-7656](https://insights.sbomify.com/CVE-2020-7656/): Cross-Site Scripting in jquery (medium 6.1)
- [CVE-2018-18405](https://insights.sbomify.com/CVE-2018-18405/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2012-6708](https://insights.sbomify.com/CVE-2012-6708/): Cross-Site Scripting in jquery (medium 6.1)
- [CVE-2014-6071](https://insights.sbomify.com/CVE-2014-6071/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-9251 and fix it if it is affected.

What it is: CVE-2015-9251 is a medium-severity vulnerability in Oracle Banking Platform, published on 18 Jan 2018. 
Exploitation: There is no known exploitation of CVE-2015-9251 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.webjars.npm:jquery (Maven): affected all versions; fixed in 1.12.2
- org.webjars.npm:jquery (Maven): affected all versions; fixed in 1.12.2
- org.webjars.npm:jquery (Maven): affected from 1.12.3; fixed in 3.0.0
- org.webjars.npm:jquery (Maven): affected from 1.12.3; fixed in 3.0.0
- jQuery (NuGet): affected all versions; fixed in 1.12.2
- jQuery (NuGet): affected all versions; fixed in 1.12.2
- jQuery (NuGet): affected from 1.12.3; fixed in 3.0.0
- jQuery (NuGet): affected from 1.12.3; fixed in 3.0.0
- jquery-rails (RubyGems): affected all versions; fixed in 4.2.0
- jquery-rails (RubyGems): affected all versions; fixed in 4.2.0
- jquery (npm): affected all versions; fixed in 1.12.2
- jquery (npm): affected all versions; fixed in 1.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-9251/ (Markdown: https://insights.sbomify.com/CVE-2015-9251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-9251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-9251
- OSV: https://osv.dev/vulnerability/CVE-2015-9251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-9251/
Summaries are generated and may contain mistakes; the official description above is the record.
