CVE-2015-9284 OmniAuth Ruby gem Cross-site Request Forgery in request phase

High 8.8 Published Updated

Attackers can force account connections via CSRF, allowing secondary accounts to sign in as primary users in Ruby on Rails applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-9284?

CVE-2015-9284 is a high-severity vulnerability in omniauth ruby gem, published on 26 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.

Weakness: CWE-352

Which versions are affected by CVE-2015-9284?

2 open source packages ship an affected version, including omniauth. It affects 1 product.

PackageAffectedFixed in
omniauth RubyGemsAll versions2.0.0
omniauth RubyGemsAll versions2.0.0

Products include Omniauth Omniauth.

How do I fix CVE-2015-9284?

Upgrade omniauth to 2.0.0 or later.

Is CVE-2015-9284 being exploited?

There is no known exploitation of CVE-2015-9284 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2015-9284, GHSA-ww4x-rwq6-qpgf, UBUNTU-CVE-2015-9284.

Is CVE-2015-9284 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free