{"answers":{"affected":"2 open source packages ship an affected version, including omniauth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-9284 in the wild and no public exploit code.","fix":"Upgrade omniauth to 2.0.0 or later.","what":"CVE-2015-9284 is a high-severity vulnerability in omniauth ruby gem, published on 26 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-9284 and fix it if it is affected.\n\nWhat it is: CVE-2015-9284 is a high-severity vulnerability in omniauth ruby gem, published on 26 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-9284 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- omniauth (RubyGems): affected all versions; fixed in 2.0.0\n- omniauth (RubyGems): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-9284/ (Markdown: https://insights.sbomify.com/CVE-2015-9284/index.md)","id":"CVE-2015-9284","markdown":"https://insights.sbomify.com/CVE-2015-9284/index.md","name":"CVE-2015-9284","record":{"aliases":["DEBIAN-CVE-2015-9284","GHSA-ww4x-rwq6-qpgf","UBUNTU-CVE-2015-9284"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OmniAuth Ruby gem","requires_auth":"none","summary":"Attackers can force account connections via CSRF, allowing secondary accounts to sign in as primary users in Ruby on Rails applications.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"omniauth","vendor":"omniauth"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OmniAuth Ruby gem Cross-site Request Forgery in request phase","id":"CVE-2015-9284","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-9285"},"packages":[{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"omniauth","purl":null,"source":"GHSA-ww4x-rwq6-qpgf"},{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"omniauth","purl":"pkg:gem/omniauth","source":"GHSA-ww4x-rwq6-qpgf"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-9282"},"products":["omniauth ruby gem"],"published":"2019-04-26","related":[{"cvss_score":9.8,"headline":"OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value","id":"CVE-2020-36599","kev_date_added":null,"published":"2022-08-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can force account connections via CSRF, allowing secondary accounts to sign in as primary users in Ruby on Rails applications.","url":"https://insights.sbomify.com/CVE-2015-9284/"}