# CVE-2015-9284: OmniAuth Ruby gem Cross-site Request Forgery in request phase

> Attackers can force account connections via CSRF, allowing secondary accounts to sign in as primary users in Ruby on Rails applications.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Apr 2019
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-9284, GHSA-ww4x-rwq6-qpgf, UBUNTU-CVE-2015-9284

## What is CVE-2015-9284?

CVE-2015-9284 is a high-severity vulnerability in omniauth ruby gem, published on 26 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2015-9284?

2 open source packages ship an affected version, including omniauth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `omniauth` | RubyGems | All versions | 2.0.0 |
| `omniauth` | RubyGems | All versions | 2.0.0 |

Products: Omniauth Omniauth.

## How do I fix CVE-2015-9284?

Upgrade omniauth to 2.0.0 or later.

## Is CVE-2015-9284 being exploited?

There is no known exploitation of CVE-2015-9284 in the wild and no public exploit code.

## Other vulnerabilities in omniauth ruby gem

- [CVE-2020-36599](https://insights.sbomify.com/CVE-2020-36599/): OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-9284 and fix it if it is affected.

What it is: CVE-2015-9284 is a high-severity vulnerability in omniauth ruby gem, published on 26 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-9284 in the wild and no public exploit code.

Affected packages and fixed versions:
- omniauth (RubyGems): affected all versions; fixed in 2.0.0
- omniauth (RubyGems): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-9284/ (Markdown: https://insights.sbomify.com/CVE-2015-9284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-9284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-9284
- OSV: https://osv.dev/vulnerability/CVE-2015-9284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-9284/
Summaries are generated and may contain mistakes; the official description above is the record.
