# CVE-2015-9286: Cross-site Scripting in NodeBB

> An attacker can inject malicious scripts into the outgoing message controller, potentially compromising user sessions or executing code in victim browsers.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Apr 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-72fv-qgj6-2w2p

## What is CVE-2015-9286?

CVE-2015-9286 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Controllers.outgoing in controllers/index.js in NodeBB before 0.7.3 has outgoing XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-9286?

2 open source packages ship an affected version, including nodebb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebb` | npm | All versions | 0.8.2 |
| `nodebb` | npm | All versions | 0.8.2 |

Products: Nodebb Nodebb.

## How do I fix CVE-2015-9286?

Upgrade nodebb to 0.8.2 or later.

## Is CVE-2015-9286 being exploited?

There is no known exploitation of CVE-2015-9286 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-26045](https://insights.sbomify.com/CVE-2023-26045/): NodeBB vulnerable to path traversal and code execution via prototype vulnerability (critical 10.0)
- [CVE-2020-15149](https://insights.sbomify.com/CVE-2020-15149/): Account takeover in NodeBB (critical 9.9)
- [CVE-2023-43187](https://insights.sbomify.com/CVE-2023-43187/): Code injection in n/a (critical 9.8)
- [CVE-2021-43786](https://insights.sbomify.com/CVE-2021-43786/): API token verification can be bypassed (critical 9.8)
- [CVE-2022-46164](https://insights.sbomify.com/CVE-2022-46164/): Account takeover via prototype vulnerability (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-9286 and fix it if it is affected.

What it is: CVE-2015-9286 is a medium-severity cross-site scripting vulnerability in n/a, published on 30 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-9286 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodebb (npm): affected all versions; fixed in 0.8.2
- nodebb (npm): affected all versions; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-9286/ (Markdown: https://insights.sbomify.com/CVE-2015-9286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-9286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-9286
- OSV: https://osv.dev/vulnerability/CVE-2015-9286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-9286/
Summaries are generated and may contain mistakes; the official description above is the record.
