# CVE-2015-9543: OpenStack Nova can leak consoleauth token into log files

> Attackers with log access can steal console authentication tokens, potentially gaining unauthorized access to virtual machine consoles.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-9543, GHSA-22jm-4hxw-35jf, PYSEC-2026-857, UBUNTU-CVE-2015-9543

## What is CVE-2015-9543?

CVE-2015-9543 is a low-severity vulnerability in n/a, published on 19 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in OpenStack Nova before 18.2.4, 19.x before 19.1.0, and 20.x before 20.1.0. It can leak consoleauth tokens into log files. An attacker with read access to the service's logs may obtain tokens used for console access. All Nova setups using novncproxy are affected. This is related to NovaProxyRequestHandlerBase.new_websocket_client in console/websocketproxy.py.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-9543?

7 open source packages ship an affected version, including nova and Nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 18.2.4, 19.1.0, 20.1.0 |
| `nova` | PyPI | All versions | 18.2.4 |
| `nova` | PyPI | From 19.0.0 | 19.1.0 |
| `nova` | PyPI | From 20.0.0 | 20.1.0 |
| `Nova` | PyPI | All versions | 18.2.4 |
| `Nova` | PyPI | From 19.0.0 | 19.1.0 |
| `Nova` | PyPI | From 20.0.0 | 20.1.0 |

Products: Openstack Nova.

## How do I fix CVE-2015-9543?

Upgrade nova to a fixed version for your release line: 18.2.4, 19.1.0 or 20.1.0.

## Is CVE-2015-9543 being exploited?

There is no known exploitation of CVE-2015-9543 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-7214](https://insights.sbomify.com/CVE-2017-7214/): OpenStack Nova logs sensitive context from notification exceptions (critical 9.8)
- [CVE-2017-17051](https://insights.sbomify.com/CVE-2017-17051/): OpenStack Nova DoS by rebuilding the same instance with a new image multiple times (high 8.6)
- [CVE-2020-17376](https://insights.sbomify.com/CVE-2020-17376/): OpenStack Nova Live migration fails to update persistent domain XML (high 8.3)
- [CVE-2017-18191](https://insights.sbomify.com/CVE-2017-18191/): OpenStack Nova Denial of service attack on the compute host (high 7.5)
- [CVE-2015-3280](https://insights.sbomify.com/CVE-2015-3280/): OpenStack Compute (nova) allows remote authenticated users to cause a denial of service (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-9543 and fix it if it is affected.

What it is: CVE-2015-9543 is a low-severity vulnerability in n/a, published on 19 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-9543 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 18.2.4, 19.1.0, 20.1.0
- nova (PyPI): affected all versions; fixed in 18.2.4
- nova (PyPI): affected from 19.0.0; fixed in 19.1.0
- nova (PyPI): affected from 20.0.0; fixed in 20.1.0
- Nova (PyPI): affected all versions; fixed in 18.2.4
- Nova (PyPI): affected from 19.0.0; fixed in 19.1.0
- Nova (PyPI): affected from 20.0.0; fixed in 20.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-9543/ (Markdown: https://insights.sbomify.com/CVE-2015-9543/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-9543
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-9543
- OSV: https://osv.dev/vulnerability/CVE-2015-9543

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-9543/
Summaries are generated and may contain mistakes; the official description above is the record.
