CVE-2016-0706 Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
Authenticated users can bypass SecurityManager restrictions to read arbitrary HTTP requests and discover session IDs via a crafted web application.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-0706?
CVE-2016-0706 is a medium-severity vulnerability in Apache Tomcat, published on 25 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Apache Tomcat 6.x before 6.0.45, 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M2 does not place org.apache.catalina.manager.StatusManagerServlet on the org/apache/catalina/core/RestrictedServlets.properties list, which allows remote authenticated users to bypass intended SecurityManager restrictions and read arbitrary HTTP requests, and consequently discover session ID values, via a crafted web application.
Weakness: CWE-200
Which versions are affected by CVE-2016-0706?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.45 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.45 |
org.apache.tomcat:tomcat Maven | From 8.0.0.RC1 | 8.0.31 |
org.apache.tomcat:tomcat Maven | From 8.0.0.RC1 | 8.0.31 |
org.apache.tomcat:tomcat Maven | From 9.0.0.M1 | 9.0.0.M2 |
org.apache.tomcat:tomcat Maven | From 9.0.0.M1 | 9.0.0.M2 |
Products include Apache Tomcat, Canonical Ubuntu Linux, Debian Debian Linux.
How do I fix CVE-2016-0706?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.45, 8.0.31 or 9.0.0.M2.
Is CVE-2016-0706 being exploited?
There is no known exploitation of CVE-2016-0706 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-6vx3-hr43-cfrh, UBUNTU-CVE-2016-0706.