# CVE-2016-0709: Path Traversal in Apache Jetspeed

> Authenticated administrators can exploit a directory traversal flaw in the import function to write arbitrary files and execute code.

- **Severity:** High 7.2 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w47p-5q88-hj5g

## What is CVE-2016-0709?

CVE-2016-0709 is a high-severity path traversal vulnerability in n/a, published on 11 Apr 2016. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Directory traversal vulnerability in the Import/Export function in the Portal Site Manager in Apache Jetspeed before 2.3.1 allows remote authenticated administrators to write to arbitrary files, and consequently execute arbitrary code, via a .. (dot dot) in a ZIP archive entry, as demonstrated by "../../webapps/x.jsp."

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-0709?

2 open source packages ship an affected version, including org.apache.portals.jetspeed-2:jetspeed. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.portals.jetspeed-2:jetspeed` | Maven | All versions | 2.3.1 |
| `org.apache.portals.jetspeed-2:jetspeed` | Maven | All versions | 2.3.1 |

Products: Apache Jetspeed.

## How do I fix CVE-2016-0709?

Upgrade org.apache.portals.jetspeed-2:jetspeed to 2.3.1 or later.

## Is CVE-2016-0709 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0709 exists.

Public exploit code:

- Apache Jetspeed Arbitrary File Upload (metasploit)
- Apache Jetspeed - Arbitrary File Upload (Metasploit) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2022-32533](https://insights.sbomify.com/CVE-2022-32533/): Apache Portals Jetspeed XSS, CSRF, SSRF, and XXE issues (critical 9.8)
- [CVE-2016-0710](https://insights.sbomify.com/CVE-2016-0710/): Apache Jetspeed vulnerable to SQL Injection (high 8.8)
- [CVE-2016-2171](https://insights.sbomify.com/CVE-2016-2171/): Missing authorization in n/a (high 7.5)
- [CVE-2016-0711](https://insights.sbomify.com/CVE-2016-0711/): Apache Jetspeed vulnerable to Cross-site Scripting (medium 6.1)
- [CVE-2016-0712](https://insights.sbomify.com/CVE-2016-0712/): Cross-site Scripting in Apache Jetspeed (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0709 and fix it if it is affected.

What it is: CVE-2016-0709 is a high-severity path traversal vulnerability in n/a, published on 11 Apr 2016. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0709 exists.

Affected packages and fixed versions:
- org.apache.portals.jetspeed-2:jetspeed (Maven): affected all versions; fixed in 2.3.1
- org.apache.portals.jetspeed-2:jetspeed (Maven): affected all versions; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0709/ (Markdown: https://insights.sbomify.com/CVE-2016-0709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0709
- OSV: https://osv.dev/vulnerability/CVE-2016-0709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0709/
Summaries are generated and may contain mistakes; the official description above is the record.
