{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.portals.jetspeed-2:jetspeed. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0710 exists.","fix":"Upgrade org.apache.portals.jetspeed-2:jetspeed to 2.3.1 or later.","what":"CVE-2016-0710 is a high-severity SQL injection vulnerability in n/a, published on 11 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-0710 and fix it if it is affected.\n\nWhat it is: CVE-2016-0710 is a high-severity SQL injection vulnerability in n/a, published on 11 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0710 exists.\n\nAffected packages and fixed versions:\n- org.apache.portals.jetspeed-2:jetspeed (Maven): affected all versions; fixed in 2.3.1\n- org.apache.portals.jetspeed-2:jetspeed (Maven): affected all versions; fixed in 2.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-0710/ (Markdown: https://insights.sbomify.com/CVE-2016-0710/index.md)","id":"CVE-2016-0710","markdown":"https://insights.sbomify.com/CVE-2016-0710/index.md","name":"CVE-2016-0710","record":{"aliases":["GHSA-88f6-79x2-xqf3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Jetspeed","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary SQL commands via the User Manager service, potentially compromising data integrity and confidentiality.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jetspeed","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed before 2.3.1 allow remote attackers to execute arbitrary SQL commands via the (1) role or (2) user parameter to services/usermanager/users/.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2016-03-06","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2016-03-06","kind":"metasploit","ref":"exploit/multi/http/apache_jetspeed_file_upload","stars":null,"title":"Apache Jetspeed Arbitrary File Upload"},{"date":"2016-03-31","kind":"exploitdb","ref":"39643","stars":null,"title":"Apache Jetspeed - Arbitrary File Upload (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"Apache Jetspeed vulnerable to SQL Injection","id":"CVE-2016-0710","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"sql_injection","year":"2016"},"n_packages":2,"n_references":6,"next":{"headline":"Apache Jetspeed vulnerable to Cross-site Scripting","id":"CVE-2016-0711"},"packages":[{"ecosystem":"Maven","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.portals.jetspeed-2:jetspeed","purl":null,"source":"GHSA-88f6-79x2-xqf3"},{"ecosystem":"Maven","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.portals.jetspeed-2:jetspeed","purl":"pkg:maven/org.apache.portals.jetspeed-2/jetspeed","source":"GHSA-88f6-79x2-xqf3"}],"prev":{"headline":"Path Traversal in Apache Jetspeed","id":"CVE-2016-0709"},"products":["n/a"],"published":"2016-04-11","related":[{"cvss_score":9.8,"headline":"Apache Portals Jetspeed XSS, CSRF, SSRF, and XXE issues","id":"CVE-2022-32533","kev_date_added":null,"published":"2022-07-06"},{"cvss_score":7.5,"headline":"Missing authorization in n/a","id":"CVE-2016-2171","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":7.2,"headline":"Path Traversal in Apache Jetspeed","id":"CVE-2016-0709","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":6.1,"headline":"Apache Jetspeed vulnerable to Cross-site Scripting","id":"CVE-2016-0711","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":6.1,"headline":"Cross-site Scripting in Apache Jetspeed","id":"CVE-2016-0712","kev_date_added":null,"published":"2016-04-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary SQL commands via the User Manager service, potentially compromising data integrity and confidentiality.","url":"https://insights.sbomify.com/CVE-2016-0710/"}