# CVE-2016-0710: Apache Jetspeed vulnerable to SQL Injection

> Remote attackers can execute arbitrary SQL commands via the User Manager service, potentially compromising data integrity and confidentiality.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-88f6-79x2-xqf3

## What is CVE-2016-0710?

CVE-2016-0710 is a high-severity SQL injection vulnerability in n/a, published on 11 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Multiple SQL injection vulnerabilities in the User Manager service in Apache Jetspeed before 2.3.1 allow remote attackers to execute arbitrary SQL commands via the (1) role or (2) user parameter to services/usermanager/users/.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2016-0710?

2 open source packages ship an affected version, including org.apache.portals.jetspeed-2:jetspeed. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.portals.jetspeed-2:jetspeed` | Maven | All versions | 2.3.1 |
| `org.apache.portals.jetspeed-2:jetspeed` | Maven | All versions | 2.3.1 |

Products: Apache Jetspeed.

## How do I fix CVE-2016-0710?

Upgrade org.apache.portals.jetspeed-2:jetspeed to 2.3.1 or later.

## Is CVE-2016-0710 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0710 exists.

Public exploit code:

- Apache Jetspeed Arbitrary File Upload (metasploit)
- Apache Jetspeed - Arbitrary File Upload (Metasploit) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2022-32533](https://insights.sbomify.com/CVE-2022-32533/): Apache Portals Jetspeed XSS, CSRF, SSRF, and XXE issues (critical 9.8)
- [CVE-2016-2171](https://insights.sbomify.com/CVE-2016-2171/): Missing authorization in n/a (high 7.5)
- [CVE-2016-0709](https://insights.sbomify.com/CVE-2016-0709/): Path Traversal in Apache Jetspeed (high 7.2)
- [CVE-2016-0711](https://insights.sbomify.com/CVE-2016-0711/): Apache Jetspeed vulnerable to Cross-site Scripting (medium 6.1)
- [CVE-2016-0712](https://insights.sbomify.com/CVE-2016-0712/): Cross-site Scripting in Apache Jetspeed (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0710 and fix it if it is affected.

What it is: CVE-2016-0710 is a high-severity SQL injection vulnerability in n/a, published on 11 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0710 exists.

Affected packages and fixed versions:
- org.apache.portals.jetspeed-2:jetspeed (Maven): affected all versions; fixed in 2.3.1
- org.apache.portals.jetspeed-2:jetspeed (Maven): affected all versions; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0710/ (Markdown: https://insights.sbomify.com/CVE-2016-0710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0710
- OSV: https://osv.dev/vulnerability/CVE-2016-0710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0710/
Summaries are generated and may contain mistakes; the official description above is the record.
