{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.portals.jetspeed-2:jetspeed-commons. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-0711 in the wild and no public exploit code.","fix":"Upgrade org.apache.portals.jetspeed-2:jetspeed-commons to 2.3.1 or later.","what":"CVE-2016-0711 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-0711 and fix it if it is affected.\n\nWhat it is: CVE-2016-0711 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-0711 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.portals.jetspeed-2:jetspeed-commons (Maven): affected all versions; fixed in 2.3.1\n- org.apache.portals.jetspeed-2:jetspeed-commons (Maven): affected all versions; fixed in 2.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-0711/ (Markdown: https://insights.sbomify.com/CVE-2016-0711/index.md)","id":"CVE-2016-0711","markdown":"https://insights.sbomify.com/CVE-2016-0711/index.md","name":"CVE-2016-0711","record":{"aliases":["GHSA-5pgm-9g57-3wc7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Jetspeed portal","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the title parameter when adding resources in Apache Jetspeed.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jetspeed","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in Apache Jetspeed before 2.3.1 allow remote attackers to inject arbitrary web script or HTML via the title parameter when adding a (1) link, (2) page, or (3) folder resource.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Jetspeed vulnerable to Cross-site Scripting","id":"CVE-2016-0711","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting in Apache Jetspeed","id":"CVE-2016-0712"},"packages":[{"ecosystem":"Maven","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.portals.jetspeed-2:jetspeed-commons","purl":null,"source":"GHSA-5pgm-9g57-3wc7"},{"ecosystem":"Maven","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.portals.jetspeed-2:jetspeed-commons","purl":"pkg:maven/org.apache.portals.jetspeed-2/jetspeed-commons","source":"GHSA-5pgm-9g57-3wc7"}],"prev":{"headline":"Apache Jetspeed vulnerable to SQL Injection","id":"CVE-2016-0710"},"products":["n/a"],"published":"2016-04-11","related":[{"cvss_score":9.8,"headline":"Apache Portals Jetspeed XSS, CSRF, SSRF, and XXE issues","id":"CVE-2022-32533","kev_date_added":null,"published":"2022-07-06"},{"cvss_score":8.8,"headline":"Apache Jetspeed vulnerable to SQL Injection","id":"CVE-2016-0710","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":7.5,"headline":"Missing authorization in n/a","id":"CVE-2016-2171","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":7.2,"headline":"Path Traversal in Apache Jetspeed","id":"CVE-2016-0709","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":6.1,"headline":"Cross-site Scripting in Apache Jetspeed","id":"CVE-2016-0712","kev_date_added":null,"published":"2016-04-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the title parameter when adding resources in Apache Jetspeed.","url":"https://insights.sbomify.com/CVE-2016-0711/"}