# CVE-2016-0711: Apache Jetspeed vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML via the title parameter when adding resources in Apache Jetspeed.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5pgm-9g57-3wc7

## What is CVE-2016-0711?

CVE-2016-0711 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Apache Jetspeed before 2.3.1 allow remote attackers to inject arbitrary web script or HTML via the title parameter when adding a (1) link, (2) page, or (3) folder resource.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-0711?

2 open source packages ship an affected version, including org.apache.portals.jetspeed-2:jetspeed-commons. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.portals.jetspeed-2:jetspeed-commons` | Maven | All versions | 2.3.1 |
| `org.apache.portals.jetspeed-2:jetspeed-commons` | Maven | All versions | 2.3.1 |

Products: Apache Jetspeed.

## How do I fix CVE-2016-0711?

Upgrade org.apache.portals.jetspeed-2:jetspeed-commons to 2.3.1 or later.

## Is CVE-2016-0711 being exploited?

There is no known exploitation of CVE-2016-0711 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-32533](https://insights.sbomify.com/CVE-2022-32533/): Apache Portals Jetspeed XSS, CSRF, SSRF, and XXE issues (critical 9.8)
- [CVE-2016-0710](https://insights.sbomify.com/CVE-2016-0710/): Apache Jetspeed vulnerable to SQL Injection (high 8.8)
- [CVE-2016-2171](https://insights.sbomify.com/CVE-2016-2171/): Missing authorization in n/a (high 7.5)
- [CVE-2016-0709](https://insights.sbomify.com/CVE-2016-0709/): Path Traversal in Apache Jetspeed (high 7.2)
- [CVE-2016-0712](https://insights.sbomify.com/CVE-2016-0712/): Cross-site Scripting in Apache Jetspeed (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0711 and fix it if it is affected.

What it is: CVE-2016-0711 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-0711 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.portals.jetspeed-2:jetspeed-commons (Maven): affected all versions; fixed in 2.3.1
- org.apache.portals.jetspeed-2:jetspeed-commons (Maven): affected all versions; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0711/ (Markdown: https://insights.sbomify.com/CVE-2016-0711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0711
- OSV: https://osv.dev/vulnerability/CVE-2016-0711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0711/
Summaries are generated and may contain mistakes; the official description above is the record.
