CVE-2016-0714 Improper Access Control in Apache Tomcat
Authenticated users can bypass SecurityManager restrictions to execute arbitrary code in a privileged context via crafted session objects.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-0714?
CVE-2016-0714 is a high-severity vulnerability in Apache Tomcat, published on 25 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The session-persistence implementation in Apache Tomcat 6.x before 6.0.45, 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M2 mishandles session attributes, which allows remote authenticated users to bypass intended SecurityManager restrictions and execute arbitrary code in a privileged context via a web application that places a crafted object in a session.
Weakness: CWE-264
Which versions are affected by CVE-2016-0714?
8 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.46 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.46 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.70 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.70 |
org.apache.tomcat:tomcat Maven | From 8.0.0.RC1 | 8.0.32 |
org.apache.tomcat:tomcat Maven | From 8.0.0.RC1 | 8.0.32 |
2 more packages
org.apache.tomcat:tomcat Maven | From 9.0.0.M1 | 9.0.0.M2 |
org.apache.tomcat:tomcat Maven | From 9.0.0.M1 | 9.0.0.M2 |
Products include Apache Tomcat, Canonical Ubuntu Linux, Debian Debian Linux.
How do I fix CVE-2016-0714?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.46, 7.0.70, 8.0.32 or 9.0.0.M2.
Is CVE-2016-0714 being exploited?
There is no known exploitation of CVE-2016-0714 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-mv42-px54-87jw, UBUNTU-CVE-2016-0714.