CVE-2016-0725 Moodle Cross-site scripting (XSS) vulnerability in course management search
Remote attackers can inject arbitrary web script or HTML via a crafted search string in Moodle's search pagination function.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-0725?
CVE-2016-0725 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.
Weakness: CWE-79
Which versions are affected by CVE-2016-0725?
6 open source packages ship an affected version, including moodle/moodle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.8 | 2.8.10 |
moodle/moodle Packagist | From 2.8 | 2.8.10 |
moodle/moodle Packagist | From 2.9 | 2.9.4 |
moodle/moodle Packagist | From 2.9 | 2.9.4 |
moodle/moodle Packagist | From 3.0 | 3.0.2 |
moodle/moodle Packagist | From 3.0 | 3.0.2 |
Products include Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2016-0725?
Upgrade moodle/moodle to a fixed version for your release line: 2.8.10, 2.9.4 or 3.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-0725 being exploited?
There is no known exploitation of CVE-2016-0725 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as GHSA-gj2j-ppjq-9pjg.