{"answers":{"affected":"6 open source packages ship an affected version, including moodle/moodle. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-0725 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.8.10, 2.9.4 or 3.0.2.","what":"CVE-2016-0725 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-0725 and fix it if it is affected.\n\nWhat it is: CVE-2016-0725 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-0725 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 2.8; fixed in 2.8.10\n- moodle/moodle (Packagist): affected from 2.8; fixed in 2.8.10\n- moodle/moodle (Packagist): affected from 2.9; fixed in 2.9.4\n- moodle/moodle (Packagist): affected from 2.9; fixed in 2.9.4\n- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.2\n- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-0725/ (Markdown: https://insights.sbomify.com/CVE-2016-0725/index.md)","id":"CVE-2016-0725","markdown":"https://insights.sbomify.com/CVE-2016-0725/index.md","name":"CVE-2016-0725","record":{"aliases":["GHSA-gj2j-ppjq-9pjg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via a crafted search string in Moodle's search pagination function.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"moodle","vendor":"moodle"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Cross-site scripting (XSS) vulnerability in course management search","id":"CVE-2016-0725","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"fedoraproject:fedora","products":["fedoraproject:fedora","moodle:moodle"],"type":"xss","year":"2016"},"n_packages":6,"n_references":6,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2016-0726"},"packages":[{"ecosystem":"Packagist","fixed":["2.8.10"],"introduced":["2.8"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gj2j-ppjq-9pjg"},{"ecosystem":"Packagist","fixed":["2.8.10"],"introduced":["2.8"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gj2j-ppjq-9pjg"},{"ecosystem":"Packagist","fixed":["2.9.4"],"introduced":["2.9"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gj2j-ppjq-9pjg"},{"ecosystem":"Packagist","fixed":["2.9.4"],"introduced":["2.9"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gj2j-ppjq-9pjg"},{"ecosystem":"Packagist","fixed":["3.0.2"],"introduced":["3.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gj2j-ppjq-9pjg"},{"ecosystem":"Packagist","fixed":["3.0.2"],"introduced":["3.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gj2j-ppjq-9pjg"}],"prev":{"headline":"Moodle sensitive information disclosure","id":"CVE-2016-0724"},"products":["n/a"],"published":"2016-02-22","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via a crafted search string in Moodle's search pagination function.","url":"https://insights.sbomify.com/CVE-2016-0725/"}