# CVE-2016-0725: Moodle Cross-site scripting (XSS) vulnerability in course management search

> Remote attackers can inject arbitrary web script or HTML via a crafted search string in Moodle's search pagination function.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Feb 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gj2j-ppjq-9pjg

## What is CVE-2016-0725?

CVE-2016-0725 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the search_pagination function in course/classes/management_renderer.php in Moodle 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before 3.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted search string.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-0725?

6 open source packages ship an affected version, including moodle/moodle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 2.8 | 2.8.10 |
| `moodle/moodle` | Packagist | From 2.8 | 2.8.10 |
| `moodle/moodle` | Packagist | From 2.9 | 2.9.4 |
| `moodle/moodle` | Packagist | From 2.9 | 2.9.4 |
| `moodle/moodle` | Packagist | From 3.0 | 3.0.2 |
| `moodle/moodle` | Packagist | From 3.0 | 3.0.2 |

Products: Fedoraproject Fedora, Moodle Moodle.

## How do I fix CVE-2016-0725?

Upgrade moodle/moodle to a fixed version for your release line: 2.8.10, 2.9.4 or 3.0.2.

## Is CVE-2016-0725 being exploited?

There is no known exploitation of CVE-2016-0725 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0725 and fix it if it is affected.

What it is: CVE-2016-0725 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-0725 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.8; fixed in 2.8.10
- moodle/moodle (Packagist): affected from 2.8; fixed in 2.8.10
- moodle/moodle (Packagist): affected from 2.9; fixed in 2.9.4
- moodle/moodle (Packagist): affected from 2.9; fixed in 2.9.4
- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.2
- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0725/ (Markdown: https://insights.sbomify.com/CVE-2016-0725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0725
- OSV: https://osv.dev/vulnerability/CVE-2016-0725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0725/
Summaries are generated and may contain mistakes; the official description above is the record.
