# CVE-2016-0734: Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ

> Missing X-Frame-Options header in Apache ActiveMQ admin console allows remote attackers to perform clickjacking attacks via crafted web pages.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-w525-w93j-rxgm

## What is CVE-2016-0734?

CVE-2016-0734 is a medium-severity vulnerability in Apache Activemq, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The web-based administration console in Apache ActiveMQ 5.x before 5.13.2 does not send an X-Frame-Options HTTP header, which makes it easier for remote attackers to conduct clickjacking attacks via a crafted web page that contains a (1) FRAME or (2) IFRAME element.

Weakness: CWE-254

## Which versions are affected by CVE-2016-0734?

2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.13.2 |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.13.2 |

Products: Apache Activemq.

## How do I fix CVE-2016-0734?

Upgrade org.apache.activemq:activemq-client to 5.13.2 or later.

## Is CVE-2016-0734 being exploited?

There is no known exploitation of CVE-2016-0734 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0734 and fix it if it is affected.

What it is: CVE-2016-0734 is a medium-severity vulnerability in Apache Activemq, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-0734 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.13.2
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0734/ (Markdown: https://insights.sbomify.com/CVE-2016-0734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0734
- OSV: https://osv.dev/vulnerability/CVE-2016-0734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0734/
Summaries are generated and may contain mistakes; the official description above is the record.
