CVE-2016-0738 OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service

High 7.5 Published Updated

Remote attackers can cause denial of service in OpenStack Swift by sending interrupted requests to Large Object URLs, exhausting proxy-server resources.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-0738?

CVE-2016-0738 is a high-severity denial of service vulnerability in n/a, published on 29 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenStack Object Storage (Swift) before 2.3.1 (Kilo), 2.4.x, and 2.5.x before 2.5.1 (Liberty) do not properly close server connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.

Weakness: CWE-399

Which versions are affected by CVE-2016-0738?

5 open source packages ship an affected version, including swift. It affects 1 product.

PackageAffectedFixed in
swift PyPIAll versions2.3.1, 2.5.1
swift PyPIAll versions2.3.1
swift PyPIAll versions2.3.1
swift PyPIFrom 2.4.02.5.1
swift PyPIFrom 2.4.02.5.1

Products include Openstack Swift.

How do I fix CVE-2016-0738?

Upgrade swift to a fixed version for your release line: 2.3.1 or 2.5.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2016-0738 being exploited?

There is no known exploitation of CVE-2016-0738 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2016-0738, GHSA-fxwr-2vxm-cg7p, PYSEC-2026-932, UBUNTU-CVE-2016-0738.

Is CVE-2016-0738 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free