# CVE-2016-0738: OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service

> Remote attackers can cause denial of service in OpenStack Swift by sending interrupted requests to Large Object URLs, exhausting proxy-server resources.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-0738, GHSA-fxwr-2vxm-cg7p, PYSEC-2026-932, UBUNTU-CVE-2016-0738

## What is CVE-2016-0738?

CVE-2016-0738 is a high-severity denial of service vulnerability in n/a, published on 29 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenStack Object Storage (Swift) before 2.3.1 (Kilo), 2.4.x, and 2.5.x before 2.5.1 (Liberty) do not properly close server connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.

Weakness: CWE-399

## Which versions are affected by CVE-2016-0738?

5 open source packages ship an affected version, including swift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swift` | PyPI | All versions | 2.3.1, 2.5.1 |
| `swift` | PyPI | All versions | 2.3.1 |
| `swift` | PyPI | All versions | 2.3.1 |
| `swift` | PyPI | From 2.4.0 | 2.5.1 |
| `swift` | PyPI | From 2.4.0 | 2.5.1 |

Products: Openstack Swift.

## How do I fix CVE-2016-0738?

Upgrade swift to a fixed version for your release line: 2.3.1 or 2.5.1.

## Is CVE-2016-0738 being exploited?

There is no known exploitation of CVE-2016-0738 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-0737](https://insights.sbomify.com/CVE-2016-0737/): OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service (high 7.5)
- [CVE-2026-49017](https://insights.sbomify.com/CVE-2026-49017/): OpenStack Swift: s3api middleware enters an infinite loop when processing a truncated aws-chunked PUT request body (high 7.1)
- [CVE-2013-6396](https://insights.sbomify.com/CVE-2013-6396/): Python Swift client is vulnerable to Missing SSL Certificate Check (medium 5.8)
- [CVE-2026-50221](https://insights.sbomify.com/CVE-2026-50221/): OpenStack Swift vulnerable to authenticated server-side request forgery (medium 5.3)
- [CVE-2015-5223](https://insights.sbomify.com/CVE-2015-5223/): OpenStack Object Storage (Swift) Sensitive Data Exposure (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0738 and fix it if it is affected.

What it is: CVE-2016-0738 is a high-severity denial of service vulnerability in n/a, published on 29 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-0738 in the wild and no public exploit code.

Affected packages and fixed versions:
- swift (PyPI): affected all versions; fixed in 2.3.1, 2.5.1
- swift (PyPI): affected all versions; fixed in 2.3.1
- swift (PyPI): affected all versions; fixed in 2.3.1
- swift (PyPI): affected from 2.4.0; fixed in 2.5.1
- swift (PyPI): affected from 2.4.0; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0738/ (Markdown: https://insights.sbomify.com/CVE-2016-0738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0738
- OSV: https://osv.dev/vulnerability/CVE-2016-0738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0738/
Summaries are generated and may contain mistakes; the official description above is the record.
