# CVE-2016-0752: Ruby on Rails Directory Traversal

> Remote attackers can read arbitrary files by exploiting path traversal in Ruby on Rails Action View when the render method is used without restrictions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Yes, since 25 Mar 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2016
- **Updated:** 21 Oct 2025
- **Also known as:** DEBIAN-CVE-2016-0752, GHSA-xrr4-p6fq-hjg7, SUSE-SU-2016:0456-1, SUSE-SU-2016:0599-1

## What is CVE-2016-0752?

CVE-2016-0752 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 allows remote attackers to read arbitrary files by leveraging an application's unrestricted use of the render method and providing a .. (dot dot) in a pathname.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-0752?

10 open source packages ship an affected version, including actionpack and actionview. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | All versions | 3.2.22.1 |
| `actionpack` | RubyGems | All versions | 3.2.22.1 |
| `actionpack` | RubyGems | From 4.0.0 | 4.1.14.1 |
| `actionpack` | RubyGems | From 4.0.0 | 4.1.14.1 |
| `actionpack` | RubyGems | From 4.2.0 | 4.2.5.1 |
| `actionpack` | RubyGems | From 4.2.0 | 4.2.5.1 |
| `actionview` | RubyGems | From 4.0.0 | 4.1.14.1 |
| `actionview` | RubyGems | From 4.0.0 | 4.1.14.1 |
| `actionview` | RubyGems | From 4.2.0 | 4.2.5.1 |
| `actionview` | RubyGems | From 4.2.0 | 4.2.5.1 |
| `rubygem-actionview-4_2` | SUSE:Enterprise Storage 2.1 | All versions | 4.2.2-5.1 |
| `rubygem-actionview-4_1` | SUSE:OpenStack Cloud 5 | All versions | 4.1.9-9.1 |

Products: Debian Debian Linux, Opensuse Leap, Opensuse Opensuse, Redhat Software Collections, Rubyonrails Rails, Suse Linux Enterprise Module for Containers.

## How do I fix CVE-2016-0752?

Upgrade actionpack to a fixed version for your release line: 3.2.22.1, 4.1.14.1 or 4.2.5.1. US federal agencies must fix it by 15 Apr 2022.

## Is CVE-2016-0752 being exploited?

Yes. Attackers have exploited CVE-2016-0752 in the wild since at least 25 Mar 2022.

Public exploit code:

- https://github.com/forced-request/rails-rce-cve-2016-0752 (github_poc): https://github.com/forced-request/rails-rce-cve-2016-0752
- https://github.com/dachidahu/CVE-2016-0752 (github_poc): https://github.com/dachidahu/CVE-2016-0752
- Ruby on Rails Dynamic Render File Upload Remote Code Execution (metasploit)
- Ruby on Rails - Dynamic Render File Upload / Remote Code Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0752 and fix it if it is affected.

What it is: CVE-2016-0752 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2016-0752 in the wild since at least 25 Mar 2022.

Affected packages and fixed versions:
- actionpack (RubyGems): affected all versions; fixed in 3.2.22.1
- actionpack (RubyGems): affected all versions; fixed in 3.2.22.1
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.1.14.1
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.1.14.1
- actionpack (RubyGems): affected from 4.2.0; fixed in 4.2.5.1
- actionpack (RubyGems): affected from 4.2.0; fixed in 4.2.5.1
- actionview (RubyGems): affected from 4.0.0; fixed in 4.1.14.1
- actionview (RubyGems): affected from 4.0.0; fixed in 4.1.14.1
- actionview (RubyGems): affected from 4.2.0; fixed in 4.2.5.1
- actionview (RubyGems): affected from 4.2.0; fixed in 4.2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0752/ (Markdown: https://insights.sbomify.com/CVE-2016-0752/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0752
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0752
- OSV: https://osv.dev/vulnerability/CVE-2016-0752

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0752/
Summaries are generated and may contain mistakes; the official description above is the record.
