CVE-2016-0753 activemodel contains Improper Input Validation
Remote attackers can bypass validation steps in Ruby on Rails Active Model by exploiting instance-level writers for class accessors.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-0753?
CVE-2016-0753 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.
Which versions are affected by CVE-2016-0753?
4 open source packages ship an affected version, including activemodel. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
activemodel RubyGems | From 4.1.0 | 4.1.14.1 |
activemodel RubyGems | From 4.1.0 | 4.1.14.1 |
activemodel RubyGems | From 4.2.0 | 4.2.5.1 |
activemodel RubyGems | From 4.2.0 | 4.2.5.1 |
Linux distribution packages (2)
rubygem-activemodel-4_2 SUSE:Enterprise Storage 2.1 | All versions | 4.2.2-5.1 |
rubygem-activemodel-4_1 SUSE:OpenStack Cloud 5 | All versions | 4.1.9-9.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Rubyonrails Rails.
How do I fix CVE-2016-0753?
Upgrade activemodel to a fixed version for your release line: 4.1.14.1 or 4.2.5.1.
Is CVE-2016-0753 being exploited?
There is no known exploitation of CVE-2016-0753 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2016-0753, DLA-498-1, DLA-641-1, DLA-642-1, GHSA-543v-gj2c-r3ch, SUSE-SU-2016:0432-1 and 1 more.