# CVE-2016-0753: activemodel contains Improper Input Validation

> Remote attackers can bypass validation steps in Ruby on Rails Active Model by exploiting instance-level writers for class accessors.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-0753, DLA-498-1, DLA-641-1, DLA-642-1, GHSA-543v-gj2c-r3ch, SUSE-SU-2016:0432-1, SUSE-SU-2016:0597-1

## What is CVE-2016-0753?

CVE-2016-0753 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.

## Which versions are affected by CVE-2016-0753?

4 open source packages ship an affected version, including activemodel. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemodel` | RubyGems | From 4.1.0 | 4.1.14.1 |
| `activemodel` | RubyGems | From 4.1.0 | 4.1.14.1 |
| `activemodel` | RubyGems | From 4.2.0 | 4.2.5.1 |
| `activemodel` | RubyGems | From 4.2.0 | 4.2.5.1 |
| `rubygem-activemodel-4_2` | SUSE:Enterprise Storage 2.1 | All versions | 4.2.2-5.1 |
| `rubygem-activemodel-4_1` | SUSE:OpenStack Cloud 5 | All versions | 4.1.9-9.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Rubyonrails Rails.

## How do I fix CVE-2016-0753?

Upgrade activemodel to a fixed version for your release line: 4.1.14.1 or 4.2.5.1.

## Is CVE-2016-0753 being exploited?

There is no known exploitation of CVE-2016-0753 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0753 and fix it if it is affected.

What it is: CVE-2016-0753 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-0753 in the wild and no public exploit code.

Affected packages and fixed versions:
- activemodel (RubyGems): affected from 4.1.0; fixed in 4.1.14.1
- activemodel (RubyGems): affected from 4.1.0; fixed in 4.1.14.1
- activemodel (RubyGems): affected from 4.2.0; fixed in 4.2.5.1
- activemodel (RubyGems): affected from 4.2.0; fixed in 4.2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0753/ (Markdown: https://insights.sbomify.com/CVE-2016-0753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0753
- OSV: https://osv.dev/vulnerability/CVE-2016-0753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0753/
Summaries are generated and may contain mistakes; the official description above is the record.
