# CVE-2016-0757: OpenStack Image Service (Glance) vulnerable to Improper Access Control

> Authenticated users can modify image status and upload data by removing the last location when multiple locations are enabled.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-0757, GHSA-5xrj-ghhp-hx7p, PYSEC-2026-811, RHSA-2016:0309, RHSA-2016:0352, RHSA-2016:0354, RHSA-2016:0358, UBUNTU-CVE-2016-0757

## What is CVE-2016-0757?

CVE-2016-0757 is a medium-severity missing authorization vulnerability in n/a, published on 13 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Image Service (Glance) before 2015.1.3 (kilo) and 11.0.x before 11.0.2 (liberty), when show_multiple_locations is enabled, allow remote authenticated users to change image status and upload new image data by removing the last location of an image.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-0757?

3 open source packages ship an affected version, including glance. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glance` | PyPI | From 11.0.0 | 11.0.2 |
| `glance` | PyPI | From 11.0.0 | 11.0.2 |
| `glance` | PyPI | From 11.0.0 | 11.0.2 |
| `openstack-glance` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-5.el6ost |
| `openstack-glance-doc` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-5.el6ost |
| `python-glance` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-5.el6ost |
| `openstack-glance` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-5.el7ost |
| `openstack-glance-doc` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-5.el7ost |
| `python-glance` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-5.el7ost |
| `openstack-glance` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-4.el7ost |
| `openstack-glance-doc` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-4.el7ost |
| `python-glance` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.3-4.el7ost |
| `openstack-glance` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-2.el7ost |
| `openstack-glance-doc` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-2.el7ost |
| `python-glance` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-2.el7ost |

Products: Openstack Image Registry and Delivery Service \(Glance\).

## How do I fix CVE-2016-0757?

Upgrade glance to 11.0.2 or later.

## Is CVE-2016-0757 being exploited?

There is no known exploitation of CVE-2016-0757 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-5286](https://insights.sbomify.com/CVE-2015-5286/): OpenStack Image Service (Glance) allows remote authenticated users to bypass storage quota, cause denial of service (medium 6.8)
- [CVE-2015-1195](https://insights.sbomify.com/CVE-2015-1195/): OpenStack Glance v2 API unrestricted path traversal through filesystem:// scheme (medium 6.5)
- [CVE-2015-5251](https://insights.sbomify.com/CVE-2015-5251/): OpenStack Image Service (Glance) allows remote authenticated users to bypass access restrictions (medium 5.5)
- [CVE-2014-9493](https://insights.sbomify.com/CVE-2014-9493/): Path traversal in n/a (medium 5.5)
- [CVE-2014-9684](https://insights.sbomify.com/CVE-2014-9684/): OpenStack Glance Denial of service by creating a large number of images (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0757 and fix it if it is affected.

What it is: CVE-2016-0757 is a medium-severity missing authorization vulnerability in n/a, published on 13 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-0757 in the wild and no public exploit code.

Affected packages and fixed versions:
- glance (PyPI): affected from 11.0.0; fixed in 11.0.2
- glance (PyPI): affected from 11.0.0; fixed in 11.0.2
- glance (PyPI): affected from 11.0.0; fixed in 11.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0757/ (Markdown: https://insights.sbomify.com/CVE-2016-0757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0757
- OSV: https://osv.dev/vulnerability/CVE-2016-0757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0757/
Summaries are generated and may contain mistakes; the official description above is the record.
