CVE-2016-0763 Improper Verification of Source of a Communication Channel in Apache Tomcat
Remote authenticated users can bypass SecurityManager restrictions to read or write arbitrary application data or cause denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-0763?
CVE-2016-0763 is a medium-severity missing authorization vulnerability in Apache Tomcat, published on 25 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The setGlobalContext method in org/apache/naming/factory/ResourceLinkFactory.java in Apache Tomcat 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M3 does not consider whether ResourceLinkFactory.setGlobalContext callers are authorized, which allows remote authenticated users to bypass intended SecurityManager restrictions and read or write to arbitrary application data, or cause a denial of service (application disruption), via a web application that sets a crafted global context.
Weakness: CWE-264
Which versions are affected by CVE-2016-0763?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.68 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.68 |
org.apache.tomcat:tomcat Maven | From 8.0.0 | 8.0.32 |
org.apache.tomcat:tomcat Maven | From 8.0.0 | 8.0.32 |
org.apache.tomcat:tomcat Maven | From 9.0.0M1 | 9.0.0.M3 |
org.apache.tomcat:tomcat Maven | From 9.0.0M1 | 9.0.0.M3 |
Products include Apache Tomcat, Canonical Ubuntu Linux, Debian Debian Linux.
How do I fix CVE-2016-0763?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 7.0.68, 8.0.32 or 9.0.0.M3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2016-0763 being exploited?
There is no known exploitation of CVE-2016-0763 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-9hjv-9h75-xmpp, UBUNTU-CVE-2016-0763.