# CVE-2016-0763: Improper Verification of Source of a Communication Channel in Apache Tomcat

> Remote authenticated users can bypass SecurityManager restrictions to read or write arbitrary application data or cause denial of service.

- **Severity:** Medium 6.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2016
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-9hjv-9h75-xmpp, UBUNTU-CVE-2016-0763

## What is CVE-2016-0763?

CVE-2016-0763 is a medium-severity missing authorization vulnerability in Apache Tomcat, published on 25 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The setGlobalContext method in org/apache/naming/factory/ResourceLinkFactory.java in Apache Tomcat 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M3 does not consider whether ResourceLinkFactory.setGlobalContext callers are authorized, which allows remote authenticated users to bypass intended SecurityManager restrictions and read or write to arbitrary application data, or cause a denial of service (application disruption), via a web application that sets a crafted global context.

Weakness: CWE-264

## Which versions are affected by CVE-2016-0763?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.68 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.68 |
| `org.apache.tomcat:tomcat` | Maven | From 8.0.0 | 8.0.32 |
| `org.apache.tomcat:tomcat` | Maven | From 8.0.0 | 8.0.32 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0M1 | 9.0.0.M3 |
| `org.apache.tomcat:tomcat` | Maven | From 9.0.0M1 | 9.0.0.M3 |

Products: Apache Tomcat, Canonical Ubuntu Linux, Debian Debian Linux.

## How do I fix CVE-2016-0763?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 7.0.68, 8.0.32 or 9.0.0.M3.

## Is CVE-2016-0763 being exploited?

There is no known exploitation of CVE-2016-0763 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0763 and fix it if it is affected.

What it is: CVE-2016-0763 is a medium-severity missing authorization vulnerability in Apache Tomcat, published on 25 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-0763 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.68
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.68
- org.apache.tomcat:tomcat (Maven): affected from 8.0.0; fixed in 8.0.32
- org.apache.tomcat:tomcat (Maven): affected from 8.0.0; fixed in 8.0.32
- org.apache.tomcat:tomcat (Maven): affected from 9.0.0M1; fixed in 9.0.0.M3
- org.apache.tomcat:tomcat (Maven): affected from 9.0.0M1; fixed in 9.0.0.M3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0763/ (Markdown: https://insights.sbomify.com/CVE-2016-0763/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0763
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0763
- OSV: https://osv.dev/vulnerability/CVE-2016-0763

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0763/
Summaries are generated and may contain mistakes; the official description above is the record.
