{"answers":{"affected":"2 open source packages ship an affected version, including postgresql:pljava-public. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-0767 in the wild and no public exploit code.","fix":"Upgrade postgresql:pljava-public to 1.5.0 or later.","what":"CVE-2016-0767 is a medium-severity vulnerability in n/a, published on 6 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-0767 and fix it if it is affected.\n\nWhat it is: CVE-2016-0767 is a medium-severity vulnerability in n/a, published on 6 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-0767 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql:pljava-public (Maven): affected all versions; fixed in 1.5.0\n- postgresql:pljava-public (Maven): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-0767/ (Markdown: https://insights.sbomify.com/CVE-2016-0767/index.md)","id":"CVE-2016-0767","markdown":"https://insights.sbomify.com/CVE-2016-0767/index.md","name":"CVE-2016-0767","record":{"aliases":["GHSA-837x-xww6-7jqm"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL PL/Java","requires_auth":"low_privilege","summary":"Authenticated users with public schema usage can alter the classpath, potentially leading to privilege escalation or code execution.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pl\\/java","vendor":"pl\\/java_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL PL/Java Improper Privilege Management","id":"CVE-2016-0767","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Missing authorization in n/a","id":"CVE-2016-0768"},"packages":[{"ecosystem":"Maven","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"postgresql:pljava-public","purl":null,"source":"GHSA-837x-xww6-7jqm"},{"ecosystem":"Maven","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"postgresql:pljava-public","purl":"pkg:maven/postgresql/pljava-public","source":"GHSA-837x-xww6-7jqm"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2016-0766"},"products":["n/a"],"published":"2017-06-06","related":[{"cvss_score":6.5,"headline":"Privilege escalation in n/a","id":"CVE-2016-2192","kev_date_added":null,"published":"2017-06-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated users with public schema usage can alter the classpath, potentially leading to privilege escalation or code execution.","url":"https://insights.sbomify.com/CVE-2016-0767/"}