# CVE-2016-0767: PostgreSQL PL/Java Improper Privilege Management

> Authenticated users with public schema usage can alter the classpath, potentially leading to privilege escalation or code execution.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-837x-xww6-7jqm

## What is CVE-2016-0767?

CVE-2016-0767 is a medium-severity vulnerability in n/a, published on 6 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PostgreSQL PL/Java before 1.5.0 allows remote authenticated users with USAGE permission on the public schema to alter the public schema classpath.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2016-0767?

2 open source packages ship an affected version, including postgresql:pljava-public. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql:pljava-public` | Maven | All versions | 1.5.0 |
| `postgresql:pljava-public` | Maven | All versions | 1.5.0 |

Products: Pl\/Java Project Pl\/Java.

## How do I fix CVE-2016-0767?

Upgrade postgresql:pljava-public to 1.5.0 or later.

## Is CVE-2016-0767 being exploited?

There is no known exploitation of CVE-2016-0767 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-2192](https://insights.sbomify.com/CVE-2016-2192/): Privilege escalation in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0767 and fix it if it is affected.

What it is: CVE-2016-0767 is a medium-severity vulnerability in n/a, published on 6 Jun 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-0767 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql:pljava-public (Maven): affected all versions; fixed in 1.5.0
- postgresql:pljava-public (Maven): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0767/ (Markdown: https://insights.sbomify.com/CVE-2016-0767/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0767
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0767
- OSV: https://osv.dev/vulnerability/CVE-2016-0767

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0767/
Summaries are generated and may contain mistakes; the official description above is the record.
