# CVE-2016-0775: Pillow Buffer overflow in ImagingFliDecode

> Remote attackers can cause a denial of service via a crafted FLI file due to a buffer overflow in the Pillow imaging library.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-0775, GHSA-8xjv-v9xq-m5h9, PYSEC-2016-6, UBUNTU-CVE-2016-0775

## What is CVE-2016-0775?

CVE-2016-0775 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Buffer overflow in the ImagingFliDecode function in libImaging/FliDecode.c in Pillow before 3.1.1 allows remote attackers to cause a denial of service (crash) via a crafted FLI file.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2016-0775?

3 open source packages ship an affected version, including pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | PyPI | All versions | 3.1.1 |
| `pillow` | PyPI | All versions | 3.1.1 |
| `pillow` | PyPI | All versions | 3.1.1 |

Products: Debian Debian Linux, Python Pillow.

## How do I fix CVE-2016-0775?

Upgrade pillow to 3.1.1 or later.

## Is CVE-2016-0775 being exploited?

There is no known exploitation of CVE-2016-0775 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0775 and fix it if it is affected.

What it is: CVE-2016-0775 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 13 Apr 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-0775 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (PyPI): affected all versions; fixed in 3.1.1
- pillow (PyPI): affected all versions; fixed in 3.1.1
- pillow (PyPI): affected all versions; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0775/ (Markdown: https://insights.sbomify.com/CVE-2016-0775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0775
- OSV: https://osv.dev/vulnerability/CVE-2016-0775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0775/
Summaries are generated and may contain mistakes; the official description above is the record.
