CVE-2016-0782 Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ
Remote authenticated users can perform cross-site scripting attacks in the Apache ActiveMQ administration console to obtain sensitive information from memory dumps.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-0782?
CVE-2016-0782 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 5 Aug 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The administration web console in Apache ActiveMQ 5.x before 5.11.4, 5.12.x before 5.12.3, and 5.13.x before 5.13.2 allows remote authenticated users to conduct cross-site scripting (XSS) attacks and consequently obtain sensitive information from a Java memory dump via vectors related to creating a queue.
Weakness: CWE-79
Which versions are affected by CVE-2016-0782?
6 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-client Maven | From 5.0.0 | 5.11.4 |
org.apache.activemq:activemq-client Maven | From 5.0.0 | 5.11.4 |
org.apache.activemq:activemq-client Maven | From 5.12.0 | 5.12.3 |
org.apache.activemq:activemq-client Maven | From 5.12.0 | 5.12.3 |
org.apache.activemq:activemq-client Maven | From 5.13.0 | 5.13.2 |
org.apache.activemq:activemq-client Maven | From 5.13.0 | 5.13.2 |
Products include Apache Activemq.
How do I fix CVE-2016-0782?
Upgrade org.apache.activemq:activemq-client to a fixed version for your release line: 5.11.4, 5.12.3 or 5.13.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-0782 being exploited?
There is no known exploitation of CVE-2016-0782 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as DEBIAN-CVE-2016-0782, GHSA-8rcq-p4gh-vmj8.