{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-0782 in the wild and no public exploit code.","fix":"Upgrade org.apache.activemq:activemq-client to a fixed version for your release line: 5.11.4, 5.12.3 or 5.13.2.","what":"CVE-2016-0782 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 5 Aug 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-0782 and fix it if it is affected.\n\nWhat it is: CVE-2016-0782 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 5 Aug 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-0782 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.4\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.4\n- org.apache.activemq:activemq-client (Maven): affected from 5.12.0; fixed in 5.12.3\n- org.apache.activemq:activemq-client (Maven): affected from 5.12.0; fixed in 5.12.3\n- org.apache.activemq:activemq-client (Maven): affected from 5.13.0; fixed in 5.13.2\n- org.apache.activemq:activemq-client (Maven): affected from 5.13.0; fixed in 5.13.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-0782/ (Markdown: https://insights.sbomify.com/CVE-2016-0782/index.md)","id":"CVE-2016-0782","markdown":"https://insights.sbomify.com/CVE-2016-0782/index.md","name":"CVE-2016-0782","record":{"aliases":["DEBIAN-CVE-2016-0782","GHSA-8rcq-p4gh-vmj8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"low_privilege","summary":"Remote authenticated users can perform cross-site scripting attacks in the Apache ActiveMQ administration console to obtain sensitive information from memory dumps.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"activemq","vendor":"apache"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The administration web console in Apache ActiveMQ 5.x before 5.11.4, 5.12.x before 5.12.3, and 5.13.x before 5.13.2 allows remote authenticated users to conduct cross-site scripting (XSS) attacks and consequently obtain sensitive information from a Java memory dump via vectors related to creating a queue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ","id":"CVE-2016-0782","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:activemq","products":["apache:activemq"],"type":"xss","year":"2016"},"n_packages":6,"n_references":7,"next":{"headline":"Information disclosure in n/a","id":"CVE-2016-0783"},"packages":[{"ecosystem":"Maven","fixed":["5.11.4"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-8rcq-p4gh-vmj8"},{"ecosystem":"Maven","fixed":["5.11.4"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-8rcq-p4gh-vmj8"},{"ecosystem":"Maven","fixed":["5.12.3"],"introduced":["5.12.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-8rcq-p4gh-vmj8"},{"ecosystem":"Maven","fixed":["5.12.3"],"introduced":["5.12.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-8rcq-p4gh-vmj8"},{"ecosystem":"Maven","fixed":["5.13.2"],"introduced":["5.13.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-8rcq-p4gh-vmj8"},{"ecosystem":"Maven","fixed":["5.13.2"],"introduced":["5.13.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-8rcq-p4gh-vmj8"}],"prev":{"headline":"Cross-site scripting in Cloud Foundry","id":"CVE-2016-0781"},"products":["n/a"],"published":"2016-08-05","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote authenticated users can perform cross-site scripting attacks in the Apache ActiveMQ administration console to obtain sensitive information from memory dumps.","url":"https://insights.sbomify.com/CVE-2016-0782/"}