{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-install. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-0784 in the wild and no public exploit code.","fix":"Upgrade org.apache.openmeetings:openmeetings-install to 3.1.1 or later.","what":"CVE-2016-0784 is a medium-severity path traversal vulnerability in n/a, published on 11 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-0784 and fix it if it is affected.\n\nWhat it is: CVE-2016-0784 is a medium-severity path traversal vulnerability in n/a, published on 11 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-0784 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.openmeetings:openmeetings-install (Maven): affected from 1.9.0; fixed in 3.1.1\n- org.apache.openmeetings:openmeetings-install (Maven): affected from 1.9.0; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-0784/ (Markdown: https://insights.sbomify.com/CVE-2016-0784/index.md)","id":"CVE-2016-0784","markdown":"https://insights.sbomify.com/CVE-2016-0784/index.md","name":"CVE-2016-0784","record":{"aliases":["GHSA-8xq7-7hcx-8p8g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OpenMeetings","requires_auth":"low_privilege","summary":"Authenticated administrators can write arbitrary files via path traversal in backup imports, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"openmeetings","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in the Import/Export System Backups functionality in Apache OpenMeetings before 3.1.1 allows remote authenticated administrators to write to arbitrary files via a .. (dot dot) in a ZIP archive entry.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2016-03-31","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2016-03-31","kind":"exploitdb","ref":"39642","stars":null,"title":"Apache OpenMeetings 1.9.x \u003c 3.1.0 - '.ZIP' File Directory Traversal"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache OpenMeetings Directory Traversal vulnerability","id":"CVE-2016-0784","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2016"},"n_packages":2,"n_references":7,"next":{"headline":"Apache Struts RCE Vulnerability","id":"CVE-2016-0785"},"packages":[{"ecosystem":"Maven","fixed":["3.1.1"],"introduced":["1.9.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-install","purl":null,"source":"GHSA-8xq7-7hcx-8p8g"},{"ecosystem":"Maven","fixed":["3.1.1"],"introduced":["1.9.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-install","purl":"pkg:maven/org.apache.openmeetings/openmeetings-install","source":"GHSA-8xq7-7hcx-8p8g"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-0783"},"products":["n/a"],"published":"2016-04-11","related":[{"cvss_score":10,"headline":"Apache OpenMeetings does not correctly validate uploaded XML documents","id":"CVE-2017-7664","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: Deserialisation of untrusted data in cluster mode","id":"CVE-2024-54676","kev_date_added":null,"published":"2025-01-08"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: allows user impersonation","id":"CVE-2023-28326","kev_date_added":null,"published":"2023-03-28"},{"cvss_score":9.8,"headline":"Apache OpenMeetings RCE","id":"CVE-2016-8736","kev_date_added":null,"published":"2017-10-12"},{"cvss_score":9.8,"headline":"Apache OpenMeetings has Inadequate Encryption Strength","id":"CVE-2017-7673","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to Cross-Site Request Forgery","id":"CVE-2017-7666","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to SQL injection","id":"CVE-2017-7681","kev_date_added":null,"published":"2017-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated administrators can write arbitrary files via path traversal in backup imports, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2016-0784/"}