# CVE-2016-0784: Apache OpenMeetings Directory Traversal vulnerability

> Authenticated administrators can write arbitrary files via path traversal in backup imports, potentially leading to code execution.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8xq7-7hcx-8p8g

## What is CVE-2016-0784?

CVE-2016-0784 is a medium-severity path traversal vulnerability in n/a, published on 11 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directory traversal vulnerability in the Import/Export System Backups functionality in Apache OpenMeetings before 3.1.1 allows remote authenticated administrators to write to arbitrary files via a .. (dot dot) in a ZIP archive entry.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-0784?

2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-install. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.openmeetings:openmeetings-install` | Maven | From 1.9.0 | 3.1.1 |
| `org.apache.openmeetings:openmeetings-install` | Maven | From 1.9.0 | 3.1.1 |

Products: Apache Openmeetings.

## How do I fix CVE-2016-0784?

Upgrade org.apache.openmeetings:openmeetings-install to 3.1.1 or later.

## Is CVE-2016-0784 being exploited?

There is no known exploitation of CVE-2016-0784 in the wild and no public exploit code.

Public exploit code:

- Apache OpenMeetings 1.9.x < 3.1.0 - '.ZIP' File Directory Traversal (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2017-7664](https://insights.sbomify.com/CVE-2017-7664/): Apache OpenMeetings does not correctly validate uploaded XML documents (critical 10.0)
- [CVE-2024-54676](https://insights.sbomify.com/CVE-2024-54676/): Apache OpenMeetings: Deserialisation of untrusted data in cluster mode (critical 9.8)
- [CVE-2023-28326](https://insights.sbomify.com/CVE-2023-28326/): Apache OpenMeetings: allows user impersonation (critical 9.8)
- [CVE-2016-8736](https://insights.sbomify.com/CVE-2016-8736/): Apache OpenMeetings RCE (critical 9.8)
- [CVE-2017-7673](https://insights.sbomify.com/CVE-2017-7673/): Apache OpenMeetings has Inadequate Encryption Strength (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0784 and fix it if it is affected.

What it is: CVE-2016-0784 is a medium-severity path traversal vulnerability in n/a, published on 11 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-0784 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.openmeetings:openmeetings-install (Maven): affected from 1.9.0; fixed in 3.1.1
- org.apache.openmeetings:openmeetings-install (Maven): affected from 1.9.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0784/ (Markdown: https://insights.sbomify.com/CVE-2016-0784/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0784
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0784
- OSV: https://osv.dev/vulnerability/CVE-2016-0784

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0784/
Summaries are generated and may contain mistakes; the official description above is the record.
