CVE-2016-0785 Apache Struts RCE Vulnerability
Remote attackers can execute arbitrary code in Apache Struts applications via forced double OGNL evaluation in tag attributes.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-0785?
CVE-2016-0785 is a high-severity code injection vulnerability in Apache Struts, published on 12 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation.
Weakness: CWE-20
Which versions are affected by CVE-2016-0785?
4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | From 2.0.0 | 2.3.20.3 |
org.apache.struts:struts2-core Maven | From 2.0.0 | 2.3.20.3 |
org.apache.struts:struts2-core Maven | From 2.3.24 | 2.3.24.3 |
org.apache.struts:struts2-core Maven | From 2.3.24 | 2.3.24.3 |
Products include Apache Struts.
How do I fix CVE-2016-0785?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.20.3 or 2.3.24.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2016-0785 being exploited?
There is no known exploitation of CVE-2016-0785 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-876p-4wgc-75rx.