{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-0785 in the wild and no public exploit code.","fix":"Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.20.3 or 2.3.24.3.","what":"CVE-2016-0785 is a high-severity code injection vulnerability in Apache Struts, published on 12 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-0785 and fix it if it is affected.\n\nWhat it is: CVE-2016-0785 is a high-severity code injection vulnerability in Apache Struts, published on 12 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-0785 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.20.3\n- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.20.3\n- org.apache.struts:struts2-core (Maven): affected from 2.3.24; fixed in 2.3.24.3\n- org.apache.struts:struts2-core (Maven): affected from 2.3.24; fixed in 2.3.24.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-0785/ (Markdown: https://insights.sbomify.com/CVE-2016-0785/index.md)","id":"CVE-2016-0785","markdown":"https://insights.sbomify.com/CVE-2016-0785/index.md","name":"CVE-2016-0785","record":{"aliases":["GHSA-876p-4wgc-75rx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code in Apache Struts applications via forced double OGNL evaluation in tag attributes.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"struts","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a \"%{}\" sequence in a tag attribute, aka forced double OGNL evaluation.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Struts RCE Vulnerability","id":"CVE-2016-0785","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:struts","products":["apache:struts"],"type":"code_injection","year":"2016"},"n_packages":4,"n_references":3,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2016-0786"},"packages":[{"ecosystem":"Maven","fixed":["2.3.20.3"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":null,"source":"GHSA-876p-4wgc-75rx"},{"ecosystem":"Maven","fixed":["2.3.20.3"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":"pkg:maven/org.apache.struts/struts2-core","source":"GHSA-876p-4wgc-75rx"},{"ecosystem":"Maven","fixed":["2.3.24.3"],"introduced":["2.3.24"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":null,"source":"GHSA-876p-4wgc-75rx"},{"ecosystem":"Maven","fixed":["2.3.24.3"],"introduced":["2.3.24"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":"pkg:maven/org.apache.struts/struts2-core","source":"GHSA-876p-4wgc-75rx"}],"prev":{"headline":"Apache OpenMeetings Directory Traversal vulnerability","id":"CVE-2016-0784"},"products":["n/a"],"published":"2016-04-12","related":[{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2020-17530","kev_date_added":"2021-11-03","published":"2020-12-11"},{"cvss_score":9.8,"headline":"Apache Struts 1 Improper Input Validation","id":"CVE-2017-9791","kev_date_added":"2022-02-10","published":"2017-07-10"},{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638","kev_date_added":"2021-11-03","published":"2017-03-11"},{"cvss_score":9.8,"headline":"Apache Struts 2 Improper Input Validation","id":"CVE-2012-0391","kev_date_added":"2022-01-21","published":"2012-01-08"},{"cvss_score":8.1,"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776","kev_date_added":"2021-11-03","published":"2018-08-22"},{"cvss_score":8.1,"headline":"Apache Struts Deserialization of Untrusted Data","id":"CVE-2017-9805","kev_date_added":"2021-11-03","published":"2017-09-15"},{"cvss_score":8.1,"headline":"Apache Struts Command Injection","id":"CVE-2016-3081","kev_date_added":"2026-10-08","published":"2016-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code in Apache Struts applications via forced double OGNL evaluation in tag attributes.","url":"https://insights.sbomify.com/CVE-2016-0785/"}