CVE-2016-0788 Jenkins allows Execution of Code by Opening a JRMP Listener

Critical 9.8 Published Updated

Remote attackers can execute arbitrary code on Jenkins servers by exploiting the remoting module's JRMP listener.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-0788?

CVE-2016-0788 is a critical code injection vulnerability in Jenkins Jenkins, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The remoting module in Jenkins before 1.650 and LTS before 1.642.2 allows remote attackers to execute arbitrary code by opening a JRMP listener.

Weakness: CWE-264

Which versions are affected by CVE-2016-0788?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.642.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.642.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6431.650
org.jenkins-ci.main:jenkins-core MavenFrom 1.6431.650

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2016-0788?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.642.2 or 1.650.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2016-0788 being exploited?

There is no known exploitation of CVE-2016-0788 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-j7q5-h445-f7pc.

Is CVE-2016-0788 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free