# CVE-2016-0788: Jenkins allows Execution of Code by Opening a JRMP Listener

> Remote attackers can execute arbitrary code on Jenkins servers by exploiting the remoting module's JRMP listener.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j7q5-h445-f7pc

## What is CVE-2016-0788?

CVE-2016-0788 is a critical code injection vulnerability in Jenkins Jenkins, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The remoting module in Jenkins before 1.650 and LTS before 1.642.2 allows remote attackers to execute arbitrary code by opening a JRMP listener.

Weakness: CWE-264

## Which versions are affected by CVE-2016-0788?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.642.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.642.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.643 | 1.650 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.643 | 1.650 |

Products: Jenkins Jenkins, Redhat Openshift.

## How do I fix CVE-2016-0788?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.642.2 or 1.650.

## Is CVE-2016-0788 being exploited?

There is no known exploitation of CVE-2016-0788 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0788 and fix it if it is affected.

What it is: CVE-2016-0788 is a critical code injection vulnerability in Jenkins Jenkins, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-0788 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.642.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.642.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.643; fixed in 1.650
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.643; fixed in 1.650

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0788/ (Markdown: https://insights.sbomify.com/CVE-2016-0788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0788
- OSV: https://osv.dev/vulnerability/CVE-2016-0788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0788/
Summaries are generated and may contain mistakes; the official description above is the record.
