# CVE-2016-0790: Exposure of Sensitive Information in Jenkins Core

> Remote attackers can brute-force API tokens due to non-constant-time verification, potentially leading to unauthorized access.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jgpr-qrw2-6gp3

## What is CVE-2016-0790?

CVE-2016-0790 is a medium-severity vulnerability in Jenkins Jenkins, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins before 1.650 and LTS before 1.642.2 do not use a constant-time algorithm to verify API tokens, which makes it easier for remote attackers to determine API tokens via a brute-force approach.

Weakness: CWE-254, CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-0790?

2 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.650 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.650 |

Products: Jenkins Jenkins, Redhat Openshift.

## How do I fix CVE-2016-0790?

Upgrade org.jenkins-ci.main:jenkins-core to 1.650 or later.

## Is CVE-2016-0790 being exploited?

There is no known exploitation of CVE-2016-0790 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0790 and fix it if it is affected.

What it is: CVE-2016-0790 is a medium-severity vulnerability in Jenkins Jenkins, published on 7 Apr 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-0790 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.650
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.650

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0790/ (Markdown: https://insights.sbomify.com/CVE-2016-0790/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0790
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0790
- OSV: https://osv.dev/vulnerability/CVE-2016-0790

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0790/
Summaries are generated and may contain mistakes; the official description above is the record.
