{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0792 exists.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.642.2 or 1.650.","what":"CVE-2016-0792 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 7 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-0792 and fix it if it is affected.\n\nWhat it is: CVE-2016-0792 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 7 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0792 exists.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.642.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.642.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.643; fixed in 1.650\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.643; fixed in 1.650\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-0792/ (Markdown: https://insights.sbomify.com/CVE-2016-0792/index.md)","id":"CVE-2016-0792","markdown":"https://insights.sbomify.com/CVE-2016-0792/index.md","name":"CVE-2016-0792","record":{"aliases":["GHSA-45rg-g72w-r393","MGASA-2016-0162"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins automation server","requires_auth":"low_privilege","summary":"Remote authenticated users can execute arbitrary code via serialized data in XML files, requiring Jenkins administrators to upgrade immediately.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jenkins","vendor":"jenkins"},{"product":"openshift","vendor":"redhat"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Multiple unspecified API endpoints in Jenkins before 1.650 and LTS before 1.642.2 allow remote authenticated users to execute arbitrary code via serialized data in an XML file, related to XStream and groovy.util.Expando.","ecosystems":["Maven"],"exploits":{"exploitdb":2,"first_seen":"2016-02-24","github_poc":2,"max_poc_stars":47,"metasploit":1,"nuclei":0,"refs":[{"date":"2017-07-30T18:39:24Z","kind":"github_poc","ref":"https://github.com/jpiechowka/jenkins-cve-2016-0792","stars":47,"title":"Exploit for Jenkins serialization vulnerability - CVE-2016-0792"},{"date":"2021-09-07T13:14:16Z","kind":"github_poc","ref":"https://github.com/Aviksaikat/CVE-2016-0792","stars":1,"title":"Modified Verion of CVE-2016-0792"},{"date":"2016-02-24","kind":"metasploit","ref":"exploit/multi/http/jenkins_xstream_deserialize","stars":null,"title":"Jenkins XStream Groovy classpath Deserialization Vulnerability"},{"date":"2017-07-30","kind":"exploitdb","ref":"42394","stars":null,"title":"Jenkins \u003c 1.650 - Java Deserialization"},{"date":"2017-12-19","kind":"exploitdb","ref":"43375","stars":null,"title":"Jenkins - XStream Groovy classpath Deserialization (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"Jenkins allows Deserialization of Untrusted Data via an XML File","id":"CVE-2016-0792","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"jenkins:jenkins","products":["jenkins:jenkins","redhat:openshift"],"type":"deserialization","year":"2016"},"n_packages":4,"n_references":6,"next":{"headline":"WildFly has incomplete blacklist vulnerability","id":"CVE-2016-0793"},"packages":[{"ecosystem":"Maven","fixed":["1.642.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-45rg-g72w-r393"},{"ecosystem":"Maven","fixed":["1.642.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-45rg-g72w-r393"},{"ecosystem":"Maven","fixed":["1.650"],"introduced":["1.643"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-45rg-g72w-r393"},{"ecosystem":"Maven","fixed":["1.650"],"introduced":["1.643"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-45rg-g72w-r393"}],"prev":{"headline":"Exposure of Sensitive Information in Jenkins Core","id":"CVE-2016-0791"},"products":["n/a"],"published":"2016-04-07","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote authenticated users can execute arbitrary code via serialized data in XML files, requiring Jenkins administrators to upgrade immediately.","url":"https://insights.sbomify.com/CVE-2016-0792/"}