# CVE-2016-0792: Jenkins allows Deserialization of Untrusted Data via an XML File

> Remote authenticated users can execute arbitrary code via serialized data in XML files, requiring Jenkins administrators to upgrade immediately.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-45rg-g72w-r393, MGASA-2016-0162

## What is CVE-2016-0792?

CVE-2016-0792 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 7 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Multiple unspecified API endpoints in Jenkins before 1.650 and LTS before 1.642.2 allow remote authenticated users to execute arbitrary code via serialized data in an XML file, related to XStream and groovy.util.Expando.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-0792?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.642.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.642.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.643 | 1.650 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.643 | 1.650 |

Products: Jenkins Jenkins, Redhat Openshift.

## How do I fix CVE-2016-0792?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.642.2 or 1.650.

## Is CVE-2016-0792 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0792 exists.

Public exploit code:

- Exploit for Jenkins serialization vulnerability - CVE-2016-0792 (github_poc): https://github.com/jpiechowka/jenkins-cve-2016-0792
- Modified Verion of CVE-2016-0792 (github_poc): https://github.com/Aviksaikat/CVE-2016-0792
- Jenkins XStream Groovy classpath Deserialization Vulnerability (metasploit)
- Jenkins < 1.650 - Java Deserialization (exploitdb)
- Jenkins - XStream Groovy classpath Deserialization (Metasploit) (exploitdb)

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0792 and fix it if it is affected.

What it is: CVE-2016-0792 is a high-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 7 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0792 exists.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.642.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.642.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.643; fixed in 1.650
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.643; fixed in 1.650

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0792/ (Markdown: https://insights.sbomify.com/CVE-2016-0792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0792
- OSV: https://osv.dev/vulnerability/CVE-2016-0792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0792/
Summaries are generated and may contain mistakes; the official description above is the record.
