# CVE-2016-0956: Exposure of Sensitive Information to an Unauthorized Actor in Apache Sling Servlets Post

> Remote attackers can obtain sensitive information from the Apache Sling Servlets Post component, affecting Adobe Experience Manager deployments.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2016
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m27m-628v-xxp2

## What is CVE-2016-0956?

CVE-2016-0956 is a high-severity vulnerability in Adobe Experience Manager, published on 10 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Servlets Post component 2.3.6 in Apache Sling, as used in Adobe Experience Manager 5.6.1, 6.0.0, and 6.1.0, allows remote attackers to obtain sensitive information via unspecified vectors.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-0956?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.servlets.post. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.servlets.post` | Maven | All versions | 2.3.8 |
| `org.apache.sling:org.apache.sling.servlets.post` | Maven | All versions | 2.3.8 |

Products: Adobe Experience Manager, Apache Sling.

## How do I fix CVE-2016-0956?

Upgrade org.apache.sling:org.apache.sling.servlets.post to 2.3.8 or later.

## Is CVE-2016-0956 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0956 exists.

Public exploit code:

- Apache Sling Framework (Adobe AEM) 2.3.6 - Information Disclosure (exploitdb)

## Other vulnerabilities in Adobe Experience Manager

- [CVE-2026-90532](https://insights.sbomify.com/CVE-2026-90532/): Adobe Experience Manager | Incorrect Authorization (CWE-863) (critical 10.0)
- [CVE-2026-105895](https://insights.sbomify.com/CVE-2026-105895/): Adobe Experience Manager | Improper Input Validation (CWE-20) (critical 9.9)
- [CVE-2026-19232](https://insights.sbomify.com/CVE-2026-19232/): Adobe Experience Manager | Incorrect Authorization (CWE-863) (critical 9.9)
- [CVE-2025-49533](https://insights.sbomify.com/CVE-2025-49533/): Adobe Experience Manager (MS) | Deserialization of Untrusted Data (CWE-502) (critical 9.8)
- [CVE-2021-40722](https://insights.sbomify.com/CVE-2021-40722/): AEM Forms Improper Restriction of XML External Entity Reference (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-0956 and fix it if it is affected.

What it is: CVE-2016-0956 is a high-severity vulnerability in Adobe Experience Manager, published on 10 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-0956 exists.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.servlets.post (Maven): affected all versions; fixed in 2.3.8
- org.apache.sling:org.apache.sling.servlets.post (Maven): affected all versions; fixed in 2.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-0956/ (Markdown: https://insights.sbomify.com/CVE-2016-0956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-0956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-0956
- OSV: https://osv.dev/vulnerability/CVE-2016-0956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-0956/
Summaries are generated and may contain mistakes; the official description above is the record.
