# CVE-2016-1000027: Pivotal Spring Framework contains unsafe Java deserialization methods

> Remote code execution is possible in Spring Framework if developers configure it to deserialize untrusted data, a scenario the vendor deems out of scope.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2020
- **Updated:** 7 Oct 2026
- **Also known as:** CLEANSTART-2026-DY91786, DEBIAN-CVE-2016-1000027, GHSA-4wrc-f8pq-fpqp, MINI-564f-9jhg-rjwp, MINI-c7cw-gj96-v8hr, MINI-vccc-gfwj-g2mj, RHLW-2026-a06fd4cfdab7ef70, ROOT-APP-MAVEN-CVE-2016-1000027

## What is CVE-2016-1000027?

CVE-2016-1000027 is a critical unsafe deserialization vulnerability in Vmware Spring Framework, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2016-1000027?

2 open source packages ship an affected version, including org.springframework:spring-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-web` | Maven | All versions | 6.0.0 |
| `org.springframework:spring-web` | Maven | All versions | 6.0.0 |

Products: Vmware Spring Framework.

## How do I fix CVE-2016-1000027?

Upgrade org.springframework:spring-web to 6.0.0 or later.

## Is CVE-2016-1000027 being exploited?

There is no known exploitation of CVE-2016-1000027 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2016-1000027 (github_poc): https://github.com/artem-smotrakov/cve-2016-1000027-poc
- Mitigated version for CVE-2016-1000027 spring web. (github_poc): https://github.com/tina94happy/Spring-Web-5xx-Mitigated-version
- Spring Web 5.x with `org.springframework.remoting` package removed, to fix CVE-2016-1000027. (github_poc): https://github.com/yihtserns/spring-web-without-remoting
- validation de l'exploitabilité d'une CVE (github_poc): https://github.com/Ragatzino/test-cve-2016-1000027

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1000027 and fix it if it is affected.

What it is: CVE-2016-1000027 is a critical unsafe deserialization vulnerability in Vmware Spring Framework, published on 2 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1000027 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-web (Maven): affected all versions; fixed in 6.0.0
- org.springframework:spring-web (Maven): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1000027/ (Markdown: https://insights.sbomify.com/CVE-2016-1000027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1000027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1000027
- OSV: https://osv.dev/vulnerability/CVE-2016-1000027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1000027/
Summaries are generated and may contain mistakes; the official description above is the record.
