# CVE-2016-1000030: Code injection in n/a

> Attackers can execute arbitrary code by sending a malicious X.509 certificate to Pidgin users due to improper return value checks.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Sep 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-1000030, GHSA-mxjf-9j2x-85mg

## What is CVE-2016-1000030?

CVE-2016-1000030 is a critical code injection vulnerability in Pidgin Pidgin, published on 5 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pidgin version <2.11.0 contains a vulnerability in X.509 Certificates imports specifically due to improper check of return values from gnutls_x509_crt_init() and gnutls_x509_crt_import() that can result in code execution. This attack appear to be exploitable via custom X.509 certificate from another client. This vulnerability appears to have been fixed in 2.11.0.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2016-1000030?

It affects 2 products.


Products: Pidgin Pidgin, Suse Linux Enterprise Server.

## How do I fix CVE-2016-1000030?

Upgrade to a fixed version.

## Is CVE-2016-1000030 being exploited?

There is no known exploitation of CVE-2016-1000030 in the wild and no public exploit code.

## Other vulnerabilities in Pidgin Pidgin

- [CVE-2013-6490](https://insights.sbomify.com/CVE-2013-6490/): Memory corruption in n/a (critical 10.0)
- [CVE-2013-6486](https://insights.sbomify.com/CVE-2013-6486/): Command injection in n/a (critical 9.3)
- [CVE-2011-3185](https://insights.sbomify.com/CVE-2011-3185/): Command injection in n/a (critical 9.3)
- [CVE-2009-1376](https://insights.sbomify.com/CVE-2009-1376/): Integer overflow in n/a (critical 9.3)
- [CVE-2007-3841](https://insights.sbomify.com/CVE-2007-3841/): Command injection in n/a (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1000030 and fix it if it is affected.

What it is: CVE-2016-1000030 is a critical code injection vulnerability in Pidgin Pidgin, published on 5 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1000030 in the wild and no public exploit code.

Affected product: Pidgin Pidgin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1000030/ (Markdown: https://insights.sbomify.com/CVE-2016-1000030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1000030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1000030
- OSV: https://osv.dev/vulnerability/CVE-2016-1000030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1000030/
Summaries are generated and may contain mistakes; the official description above is the record.
