# CVE-2016-1000111: Forced Browsing in Twisted

> Remote attackers can redirect outbound HTTP traffic from CGI applications to arbitrary proxies via crafted headers, potentially exposing internal data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2020
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-1000111, GHSA-3gqj-cmxr-p4x2, MGASA-2016-0340, PYSEC-2020-214, RHSA-2016:1978, RHSA-2018:0273, SUSE-SU-2017:0114-1, UBUNTU-CVE-2016-1000111, USN-3585-1, openSUSE-SU-2024:10162-1

## What is CVE-2016-1000111?

CVE-2016-1000111 is a medium-severity server-side request forgery vulnerability in n/a, published on 11 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Twisted before 16.3.1 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect CGI applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect a CGI application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue.

Weakness: CWE-425 (Direct Request)

## Which versions are affected by CVE-2016-1000111?

3 open source packages ship an affected version, including twisted and Twisted. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twisted` | PyPI | All versions | 16.3.1 |
| `twisted` | PyPI | All versions | 16.3.1 |
| `Twisted` | PyPI | All versions | 16.3.1 |
| `python-twisted-web` | Red Hat:enterprise_linux:6::client | All versions | 0:8.2.0-5.el6_8 |
| `python-twisted-web` | Red Hat:enterprise_linux:6::server | All versions | 0:8.2.0-5.el6_8 |
| `python-twisted-web` | Red Hat:enterprise_linux:6::workstation | All versions | 0:8.2.0-5.el6_8 |
| `python-twisted-web` | Red Hat:enterprise_linux:7::client | All versions | 0:12.1.0-5.el7_2 |
| `python-twisted-web` | Red Hat:enterprise_linux:7::server | All versions | 0:12.1.0-5.el7_2 |
| `python-twisted-web` | Red Hat:enterprise_linux:7::workstation | All versions | 0:12.1.0-5.el7_2 |
| `candlepin` | Red Hat:satellite:6.1::el6 | All versions | 0:0.9.54.26-1.el6 |
| `candlepin-selinux` | Red Hat:satellite:6.1::el6 | All versions | 0:0.9.54.26-1.el6 |
| `foreman` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-compute` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-debug` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-ec2` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-gce` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-installer` | Red Hat:satellite:6.1::el6 | All versions | 1:1.11.0.18-1.el6sat |
| `foreman-installer-katello` | Red Hat:satellite:6.1::el6 | All versions | 0:3.0.0.101-1.el6sat |
| `foreman-libvirt` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-openstack` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-ovirt` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-postgresql` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-rackspace` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `foreman-vmware` | Red Hat:satellite:6.1::el6 | All versions | 0:1.11.0.86-1.el6sat |
| `katello` | Red Hat:satellite:6.1::el6 | All versions | 0:3.0.0-33.el6sat |
| `katello-capsule` | Red Hat:satellite:6.1::el6 | All versions | 0:3.0.0-33.el6sat |
| `katello-common` | Red Hat:satellite:6.1::el6 | All versions | 0:3.0.0-33.el6sat |
| `katello-debug` | Red Hat:satellite:6.1::el6 | All versions | 0:3.0.0-33.el6sat |
| `katello-installer-base` | Red Hat:satellite:6.1::el6 | All versions | 0:3.0.0.101-1.el6sat |
| `katello-service` | Red Hat:satellite:6.1::el6 | All versions | 0:3.0.0-33.el6sat |
| `libqpid-dispatch` | Red Hat:satellite:6.1::el6 | All versions | 0:0.4-27.el6sat |
| `pulp` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.18-1.el6sat |
| `pulp-admin-client` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.18-1.el6sat |
| `pulp-puppet` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.2-1.el6sat |
| `pulp-puppet-admin-extensions` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.2-1.el6sat |
| `pulp-puppet-plugins` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.2-1.el6sat |
| `pulp-puppet-tools` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.2-1.el6sat |
| `pulp-selinux` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.18-1.el6sat |
| `pulp-server` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.18-1.el6sat |
| `python-pulp-agent-lib` | Red Hat:satellite:6.1::el6 | All versions | 0:2.8.7.18-1.el6sat |

Products: Twisted Twisted.

## How do I fix CVE-2016-1000111?

Upgrade twisted to 16.3.1 or later.

## Is CVE-2016-1000111 being exploited?

There is no known exploitation of CVE-2016-1000111 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-42304](https://insights.sbomify.com/CVE-2026-42304/): Twisted: Denial of Service (DoS) in twisted.names via Crafted DNS Compression Pointer Chains (high 7.5)
- [CVE-2014-7143](https://insights.sbomify.com/CVE-2014-7143/): Python Twisted trustRoot is not respected in HTTP client (high 7.5)
- [CVE-2019-12855](https://insights.sbomify.com/CVE-2019-12855/): Improper Certificate Validation in Twisted (high 7.4)
- [CVE-2024-41810](https://insights.sbomify.com/CVE-2024-41810/): HTML injection in HTTP redirect body (medium 6.1)
- [CVE-2023-46137](https://insights.sbomify.com/CVE-2023-46137/): twisted.web has disordered HTTP pipeline response (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1000111 and fix it if it is affected.

What it is: CVE-2016-1000111 is a medium-severity server-side request forgery vulnerability in n/a, published on 11 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1000111 in the wild and no public exploit code.

Affected packages and fixed versions:
- twisted (PyPI): affected all versions; fixed in 16.3.1
- twisted (PyPI): affected all versions; fixed in 16.3.1
- Twisted (PyPI): affected all versions; fixed in 16.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1000111/ (Markdown: https://insights.sbomify.com/CVE-2016-1000111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1000111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1000111
- OSV: https://osv.dev/vulnerability/CVE-2016-1000111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1000111/
Summaries are generated and may contain mistakes; the official description above is the record.
