{"answers":{"affected":"2 open source packages ship an affected version, including logstash-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-1000221 in the wild and no public exploit code.","fix":"Upgrade logstash-core to 2.3.4 or later.","what":"CVE-2016-1000221 is a high-severity vulnerability in n/a, published on 16 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-1000221 and fix it if it is affected.\n\nWhat it is: CVE-2016-1000221 is a high-severity vulnerability in n/a, published on 16 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-1000221 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- logstash-core (RubyGems): affected all versions; fixed in 2.3.4\n- logstash-core (RubyGems): affected all versions; fixed in 2.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-1000221/ (Markdown: https://insights.sbomify.com/CVE-2016-1000221/index.md)","id":"CVE-2016-1000221","markdown":"https://insights.sbomify.com/CVE-2016-1000221/index.md","name":"CVE-2016-1000221","record":{"aliases":["GHSA-vcmm-ppqx-95ch"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Logstash Elasticsearch plugin","requires_auth":"none","summary":"An attacker with access to Logstash logs can read sensitive HTTP authorization headers due to improper logging practices in the Elasticsearch output plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"logstash","vendor":"elastic"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Logstash prior to version 2.3.4, Elasticsearch Output plugin would log to file HTTP authorization headers which could contain sensitive information.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Logstash Logs Sensitive Information","id":"CVE-2016-1000221","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Other in n/a","id":"CVE-2016-1000222"},"packages":[{"ecosystem":"RubyGems","fixed":["2.3.4"],"introduced":["0"],"last_affected":[],"package":"logstash-core","purl":null,"source":"GHSA-vcmm-ppqx-95ch"},{"ecosystem":"RubyGems","fixed":["2.3.4"],"introduced":["0"],"last_affected":[],"package":"logstash-core","purl":"pkg:gem/logstash-core","source":"GHSA-vcmm-ppqx-95ch"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-1000220"},"products":["n/a"],"published":"2017-06-16","related":[{"cvss_score":9.8,"headline":"Information disclosure in Logstash","id":"CVE-2019-7612","kev_date_added":null,"published":"2019-03-25"},{"cvss_score":8.4,"headline":"Logstash Insertion of Sensitive Information into Log File","id":"CVE-2023-46672","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.1,"headline":"Improper Limitation of a Pathname to a Restricted Directory in Logstash Leading to Arbitrary File Write","id":"CVE-2026-33466","kev_date_added":null,"published":"2026-04-08"},{"cvss_score":7.5,"headline":"Denial of service in Logstash","id":"CVE-2019-7620","kev_date_added":null,"published":"2019-10-30"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2015-5378","kev_date_added":null,"published":"2017-06-27"},{"cvss_score":7.5,"headline":"Other in n/a","id":"CVE-2016-1000222","kev_date_added":null,"published":"2017-06-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"An attacker with access to Logstash logs can read sensitive HTTP authorization headers due to improper logging practices in the Elasticsearch output plugin.","url":"https://insights.sbomify.com/CVE-2016-1000221/"}